zoukankan      html  css  js  c++  java
  • PAT 1109 Group Photo[仿真][难]

    1109 Group Photo(25 分)

    Formation is very important when taking a group photo. Given the rules of forming K rows with N people as the following:

    • The number of people in each row must be N/K (round down to the nearest integer), with all the extra people (if any) standing in the last row;

    • All the people in the rear row must be no shorter than anyone standing in the front rows;

    • In each row, the tallest one stands at the central position (which is defined to be the position (m/2+1), where m is the total number of people in that row, and the division result must be rounded down to the nearest integer);

    • In each row, other people must enter the row in non-increasing order of their heights, alternately taking their positions first to the right and then to the left of the tallest one (For example, given five people with their heights 190, 188, 186, 175, and 170, the final formation would be 175, 188, 190, 186, and 170. Here we assume that you are facing the group so your left-hand side is the right-hand side of the one at the central position.);

    • When there are many people having the same height, they must be ordered in alphabetical (increasing) order of their names, and it is guaranteed that there is no duplication of names.

    Now given the information of a group of people, you are supposed to write a program to output their formation.

    Input Specification:

    Each input file contains one test case. For each test case, the first line contains two positive integers N (104​​), the total number of people, and K (10), the total number of rows. Then N lines follow, each gives the name of a person (no more than 8 English letters without space) and his/her height (an integer in [30, 300]).

    Output Specification:

    For each case, print the formation -- that is, print the names of people in K lines. The names must be separated by exactly one space, but there must be no extra space at the end of each line. Note: since you are facing the group, people in the rear rows must be printed above the people in the front rows.

    Sample Input:

    10 3
    Tom 188
    Mike 170
    Eva 168
    Tim 160
    Joe 190
    Ann 168
    Bob 175
    Nick 186
    Amy 160
    John 159
    

    Sample Output:

    Bob Tom Joe Nick
    Ann Mike Eva
    Tim Amy John

     题目大意:模拟拍合照,假设有N个人需要排K行,有几点要求:

    1.每行必须有N/K个人(四舍五入),剩下的人排到最后一行

    2.在后一排的所有人不能比首排的人矮

    3.每一排中,最高的人站C位(m/2+1),

    4.每一排中的站法,先往最高的人右手边站,再往左手边站

    5.当身高一样时,按名字字母升序排列。

     //猛一看就觉得很难,很多要求,这是个仿真类的题目吧。

     //每一行内的人用什么数据结构来存呢?可以左右插入!

    #include <iostream>
    #include <cstring>
    #include<stdio.h>
    using namespace std;
    struct PE{
        int height;
        char name[10];
    }pe[10001],pe2[10001];
    int n,k;
    bool cmp(PE& a,PE &b){
        if(a.height>b.height)
            return true;
        else if(a.height==b.height&&strcmp(a.name,b.name)>0)
            return true;
        return false;
    }
    int main() {
        scanf("%d %d",&n,&k);
        char na[10];
        int h;
        for(int i=0;i<n;i++){
            scanf("%s %d",pe[i].name,&pe[i].height);//这里无效赋值。。
        }
        sort(pe,pe+n,cmp);
        int m=n/k;//一共k排,出最后行外每排m个人
        for(int i=0;i<k;i++){
            int st=i*k;
            for(int j=st;j<st+m;j++){
                //这right和left乱放太难控制了吧。
                //感觉实现就在眼前,就是写不出来。。气死了。            
            }
        }
    
        return 0;
    }
    View Code

    //这是我写的,写到一半写不下去了,因为不会安排。

    代码来自:https://www.liuchuo.net/archives/1926

    #include <iostream>
    #include <vector>
    #include <algorithm>
    using namespace std;
    struct node {
        string name;
        int height;
    };
    int cmp(node a, node b) {
        return a.height != b.height ? a.height > b.height : a.name < b.name;
        //这个一句代码,确实比我那个有好几return的好!
    }
    int main() {
        int n, k, m, i, j;
        cin >> n >> k;
        vector<node> stu(n);
        for(i = 0; i < n; i++)
            cin >> stu[i].name >> stu[i].height;
        sort(stu.begin(), stu.end(), cmp);
        int t = 0, row = k;
        while(row) {
            if(row == k)
                m = n - n / k * (k - 1);//这是在安排最后一行的人数。
            else
                m = n / k;
            vector<string> stemp(m);//每一行都重新定义一个向量。
            stemp[m / 2] = stu[t].name;//这个中间值很厉害了,
            //题目中给的是m/2+1,但是题目中是从1开始计数,数组中下标从0开始。
            // 左边一列
            j = m / 2 - 1;
            for(i = t + 1; i < t + m; i = i + 2)
                stemp[j--] = stu[i].name;
            // 右边一列
            j = m / 2 + 1;
            for(i = t + 2; i < t + m; i = i + 2)
                stemp[j++] = stu[i].name;
            // 输出当前排
            cout << stemp[0];
            for(i = 1; i < m; i++) cout << " " << stemp[i];
            cout << endl;
            t = t + m;
            row--;
        }
        return 0;
    }

    //厉害了,学习了。

    1.其中cmp函数就很值得学习,比我之前那样写好看多了;

    2.因为最终输出是从高到低,那么就先安排后排,安排完之后就输出,那么身高就从大到小排列。

    3.重点的问题是如何将他们按照身高C位排列。

    首先是,找到C位位置,并且将左边和右边分别用一个for来安排,

    j呢,是指示C位下标的左右的两个作为开始。

    在安排左边的时候是j--,那么对原始排序完毕的就是i+=2,跳一个赋值一个;

    对于安排右边的来说,j++,也是i+=2.

    2018-9-7更:

    那么对于原来的初始排列也有一个i指向它,起点是t,也就是上一次循环设置的,那么整个的可分配的长度就是t~t+m这么长,去按规则左右分配。

    //学习了! 

  • 相关阅读:
    SVN服务器搭建和使用
    oracle 存储过程
    PLSQL函数
    PL/SQL --> 游标
    PL SQL 游标学习
    PLSQL存储过程
    利用jqueryRotare实现抽奖转盘
    NSString 与NSMutableString的区别
    第一章 熟悉Objective -C 编写高质量iOS与OS X代码的52 个有效方法
    第8章 应用协议 图解TCP/IP 详解
  • 原文地址:https://www.cnblogs.com/BlueBlueSea/p/9526228.html
Copyright © 2011-2022 走看看