zoukankan      html  css  js  c++  java
  • PAT 1056 Mice and Rice[难][不理解]

    1056 Mice and Rice(25 分)

    Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

    First the playing order is randomly decided for NP​​ programmers. Then every NG​​ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every NG​​ winners are then grouped in the next match until a final winner is determined.

    For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 positive integers: NP​​ and NG​​ (1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than NG​​ mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains NP​​ distinct non-negative numbers Wi​​ (i=0,,NP​​1) where each Wi​​ is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,,NP​​1 (assume that the programmers are numbered from 0 to NP​​1). All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

    Sample Input:

    11 3
    25 18 0 46 37 3 19 22 57 56 10
    6 0 8 7 10 5 9 1 4 2 3
    

    Sample Output:

    5 5 5 2 5 5 5 3 1 3 5

     题目大意:

     //看了一遍题意,愣是没看懂。看了三遍还是没看懂,放弃了。看了题解上说的题意,还不不太明白,算了吧,看代码吧。

    代码来自: https://www.liuchuo.net/archives/2936

    #include <iostream>
    #include <queue>
    #include <vector>
    #include <algorithm>
    using namespace std;
    struct node {
        int weight, index, rank, index0;
    };
    bool cmp1(node a, node b) {
        return a.index0 < b.index0;
    }
    int main() {
        int n, g, num;
        scanf("%d%d", &n, &g);
        vector<int> v(n);
        vector<node> w(n);
        for(int i = 0; i < n; i++)
            scanf("%d", &v[i]);
        for(int i = 0; i < n; i++) {
            scanf("%d", &num);
            w[i].weight = v[num];//这个存的是体重
            w[i].index = i;//这个存的是第几个,这个是对应老鼠编号的。
            w[i].index0 = num;//这个存的是初始顺序。
        }
        queue<node> q;
        for(int i = 0; i < n; i++)
            q.push(w[i]);
        while(!q.empty()) {//目的是找出最胖的。
            int size = q.size();
            if(size == 1) {
                node temp = q.front();
                w[temp.index].rank = 1;
                break;
            }
            int group = size / g;
            if(size % g != 0)//这样来安排最后鼠数几个不够g的。
                group += 1;
            node maxnode;
            int maxn = -1, cnt = 0;
            for(int i = 0; i < size; i++) {
                node temp = q.front();
                w[temp.index].rank = group + 1;
                q.pop();
                cnt++;
                if(temp.weight > maxn) {
                    maxn = temp.weight;
                    maxnode = temp;
                }
                if(cnt == g || i == size - 1) {
                    cnt = 0;
                    maxn = -1;
                    q.push(maxnode);
                }
            }
        }
        sort(w.begin(), w.end(), cmp1);
        for(int i = 0; i < n; i++) {
            if(i != 0) printf(" ");
            printf("%d", w[i].rank);
        }
        return 0;
    }

    //还是不太懂什么意思,以后再说。

  • 相关阅读:
    吐槽下博客园
    关于爱情
    CCD 驱动 时序理解
    写在博客的第一天
    51单片机最小系统
    swing之登陆功能
    TDSQL | 在整个技术解决方案中HTAP对应的混合交易以及分析系统应该如何实现?
    TDSQL | 深度解读HTAP系统的问题与主义之争
    硬核干货!TDSQL全局一致性读技术详解|
    35w奖金池,腾讯云TDSQL精英挑战赛等你来战!
  • 原文地址:https://www.cnblogs.com/BlueBlueSea/p/9578547.html
Copyright © 2011-2022 走看看