zoukankan      html  css  js  c++  java
  • PAT 1038 Recover the Smallest Number[dp][难]

    1038 Recover the Smallest Number (30 分)

    Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

    Input Specification:

    Each input file contains one test case. Each case gives a positive integer N (104​​) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

    Sample Input:

    5 32 321 3214 0229 87
    

    Sample Output:

    22932132143287

     题目大意:给出几个数,要求求出它们的片段拼接,并且这个数是所有数中最小的。

    //一看到就不太明白怎么做,拼接不同总长度也不一定相同,有0开头的,如果放在中间的话就算是中间一位了。没什么思路,考试遇到这个的话会跪。 

     代码来自:https://www.liuchuo.net/archives/2303

    #include <iostream>
    #include <string>
    #include <algorithm>
    using namespace std;
    bool cmp0(string a, string b) {//两个相同的数相加,它们的长度肯定是相同的。
        return a + b < b + a;
    }
    string str[10010];//使用字符串数组!
    int main() {
        int n;
        scanf("%d", &n);
        for(int i = 0; i < n; i++)
            cin >> str[i];//以String作为输入。
        sort(str, str + n, cmp0);
        string s;
        for(int i = 0; i < n; i++)
            s += str[i];//将字符串拼接。
        while(s.length() != 0 && s[0] == '0')
            s.erase(s.begin());//将开头的0除去。
        if(s.length() == 0) cout << 0;
        cout << s;
        return 0;
    }

    //柳神的代码简直叹为观止。厉害了,学习了。 

     1.对字符串的处理,关键是这个cmp0函数的使用。

  • 相关阅读:
    bzoj4105: [Thu Summer Camp 2015]平方运算
    bzoj4035: [HAOI2015]数组游戏
    bzoj1022: [SHOI2008]小约翰的游戏John
    bzoj4665: 小w的喜糖
    CodeChef:Little Elephant and Colored Coins
    bzoj4664: Count
    bzoj4498: 魔法的碰撞
    bzoj4230: 倒计时
    bzoj4532: [BeiJing2014 WinterCamp] 珠链
    python 画正态曲线
  • 原文地址:https://www.cnblogs.com/BlueBlueSea/p/9692303.html
Copyright © 2011-2022 走看看