zoukankan      html  css  js  c++  java
  • PAT 1093 Count PAT's[比较]

    1093 Count PAT's (25 分)

    The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

    Now given any string, you are supposed to tell the number of PAT's contained in the string.

    Input Specification:

    Each input file contains one test case. For each case, there is only one line giving a string of no more than 105​​ characters containing only PA, or T.

    Output Specification:

    For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

    Sample Input:

    APPAPT
    

    Sample Output:

    2

     题目大意:给出一个字符串,判断其中有多少个PAT串,P A T之间可以有其他字符隔开。

    //只要计算每个出现的A之前出现的P的总数,和A之后出现的T的总数,两者相乘,对所有的A的结果相加即可。

    #include <iostream>
    #include <algorithm>
    #include<cstdio>
    #include<stdio.h>
    #include <queue>
    #include<cmath>
    #include <vector>
    using namespace std;
    
    int cntP[100010];
    int main()
    {
        string s;
        cin>>s;
        int ct=0;//首先在字符串里找出所有A的位置。
        vector<int> posA;
        posA.push_back(0);
        int pos=0;
        while(s.find("A",pos)!=string::npos){
            pos=s.find("A",pos);
            posA.push_back(pos);
            pos++;
        }
        //vector<int> cntP(posA.size());
        int index=1;//开始计算P的数量
        for(int i=0;i<s.size();i++){
            if(i<posA[index]){
                if(s[i]=='P'){
                    cntP[index-1]++;
                }
            }
            if(i==posA[index]){
                cntP[index]+=cntP[index-1];
            }
        }
        for(int i=0;i<posA.size();i++)
            cout<<cntP[i];
    
    
        return 0;
    }

    //我写成了这个样子,但是感觉还是不行的。写不下去了。

    下面是柳神的解答,真的太厉害了!!!

    //真是恍然大悟的感觉。学习了!

  • 相关阅读:
    SQLServer数据库优化常用语句
    雷军:用互联网思维改造传统产业
    互联网公司该向东莞学什么?
    企业管理:中层领导必看:什么叫工作到位?
    Web页面工作流设计器
    雷军:用互联网思维改造传统产业
    生成html页面客户端随机数和验证码
    IIS应用程序池频繁停止,任务管理器发现有多个w3wp.exe进程
    检测SqlServer服务器性能
    利用任务计划自动删除指定日期文件
  • 原文地址:https://www.cnblogs.com/BlueBlueSea/p/9941620.html
Copyright © 2011-2022 走看看