zoukankan      html  css  js  c++  java
  • AtCoder Regular Contest 096

    在那边985月赛皮,掉分预定

    C - Half and Half


    Time limit : 2sec / Memory limit : 256MB

    Score : 300 points

    Problem Statement

    "Pizza At", a fast food chain, offers three kinds of pizza: "A-pizza", "B-pizza" and "AB-pizza". A-pizza and B-pizza are completely different pizzas, and AB-pizza is one half of A-pizza and one half of B-pizza combined together. The prices of one A-pizza, B-pizza and AB-pizza are A yen, B yen and C yen (yen is the currency of Japan), respectively.

    Nakahashi needs to prepare X A-pizzas and Y B-pizzas for a party tonight. He can only obtain these pizzas by directly buying A-pizzas and B-pizzas, or buying two AB-pizzas and then rearrange them into one A-pizza and one B-pizza. At least how much money does he need for this? It is fine to have more pizzas than necessary by rearranging pizzas.

    Constraints

    • 1≤A,B,C≤5000
    • 1≤X,Y≤105
    • All values in input are integers.

    Input

    Input is given from Standard Input in the following format:

    A B C X Y
    

    Output

    Print the minimum amount of money required to prepare X A-pizzas and Y B-pizzas.


    Sample Input 1

    Copy
    1500 2000 1600 3 2
    

    Sample Output 1

    Copy
    7900
    

    It is optimal to buy four AB-pizzas and rearrange them into two A-pizzas and two B-pizzas, then buy additional one A-pizza.


    Sample Input 2

    Copy
    1500 2000 1900 3 2
    

    Sample Output 2

    Copy
    8500
    

    It is optimal to directly buy three A-pizzas and two B-pizzas.


    Sample Input 3

    Copy
    1500 2000 500 90000 100000
    

    Sample Output 3

    Copy
    100000000
    

    It is optimal to buy 200000 AB-pizzas and rearrange them into 100000 A-pizzas and 100000 B-pizzas. We will have 10000 more A-pizzas than necessary, but that is fine.


    三种情况直接列举下

    #include<bits/stdc++.h>
    using namespace std;
    typedef long long ll;
    int main()
    {
        ll a,b,c,x,y;
        cin>>a>>b>>c>>x>>y;
        ll ans=max(x,y)*2*c;
        ans=min(ans,min(x,y)*2*c+(y>x?(y-x)*b:(x-y)*a));
        ans=min(ans,a*x+b*y);
        cout<<ans;
        return 0;
    }

    D - Static Sushi


    Time limit : 2sec / Memory limit : 256MB

    Score : 500 points

    Problem Statement

    "Teishi-zushi", a Japanese restaurant, is a plain restaurant with only one round counter. The outer circumference of the counter is C meters. Customers cannot go inside the counter.

    Nakahashi entered Teishi-zushi, and he was guided to the counter. Now, there are N pieces of sushi (vinegared rice with seafood and so on) on the counter. The distance measured clockwise from the point where Nakahashi is standing to the point where the i-th sushi is placed, is xi meters. Also, the i-th sushi has a nutritive value of vi kilocalories.

    Nakahashi can freely walk around the circumference of the counter. When he reach a point where a sushi is placed, he can eat that sushi and take in its nutrition (naturally, the sushi disappears). However, while walking, he consumes 1 kilocalories per meter.

    Whenever he is satisfied, he can leave the restaurant from any place (he does not have to return to the initial place). On balance, at most how much nutrition can he take in before he leaves? That is, what is the maximum possible value of the total nutrition taken in minus the total energy consumed? Assume that there are no other customers, and no new sushi will be added to the counter. Also, since Nakahashi has plenty of nutrition in his body, assume that no matter how much he walks and consumes energy, he never dies from hunger.

    Constraints

    • 1≤N≤105
    • 2≤C≤1014
    • 1≤x1<x2<…<xN<C
    • 1≤vi≤109
    • All values in input are integers.

    Subscores

    • 300 points will be awarded for passing the test set satisfying N≤100.

    Input

    Input is given from Standard Input in the following format:

    N C
    x1 v1
    x2 v2
    :
    xN vN
    

    Output

    If Nakahashi can take in at most c kilocalories on balance before he leaves the restaurant, print c.


    Sample Input 1

    Copy
    3 20
    2 80
    9 120
    16 1
    

    Sample Output 1

    Copy
    191
    

    There are three sushi on the counter with a circumference of 20 meters. If he walks two meters clockwise from the initial place, he can eat a sushi of 80kilocalories. If he walks seven more meters clockwise, he can eat a sushi of 120 kilocalories. If he leaves now, the total nutrition taken in is 200 kilocalories, and the total energy consumed is 9 kilocalories, thus he can take in 191 kilocalories on balance, which is the largest possible value.


    Sample Input 2

    Copy
    3 20
    2 80
    9 1
    16 120
    

    Sample Output 2

    Copy
    192
    

    The second and third sushi have been swapped. Again, if he walks two meters clockwise from the initial place, he can eat a sushi of 80 kilocalories. If he walks six more meters counterclockwise this time, he can eat a sushi of 120 kilocalories. If he leaves now, the total nutrition taken in is 200 kilocalories, and the total energy consumed is 8 kilocalories, thus he can take in 192 kilocalories on balance, which is the largest possible value.


    Sample Input 3

    Copy
    1 100000000000000
    50000000000000 1
    

    Sample Output 3

    Copy
    0
    

    Even though the only sushi is so far that it does not fit into a 32-bit integer, its nutritive value is low, thus he should immediately leave without doing anything.


    Sample Input 4

    Copy
    15 10000000000
    400000000 1000000000
    800000000 1000000000
    1900000000 1000000000
    2400000000 1000000000
    2900000000 1000000000
    3300000000 1000000000
    3700000000 1000000000
    3800000000 1000000000
    4000000000 1000000000
    4100000000 1000000000
    5200000000 1000000000
    6600000000 1000000000
    8000000000 1000000000
    9300000000 1000000000
    9700000000 1000000000
    

    Sample Output 4

    Copy
    6500000000
    

    All these sample inputs above are included in the test set for the partial score.


    这个需要dp的,想不到哇,还要前缀和优化

    #include <bits/stdc++.h>
    using namespace std;
    typedef long long ll;
    const int N=1e5+5;
    long long a[N],b[N],c[N],d[N],e[N],f[N],m,n;
    int main()
    {
        cin>>n>>m;
        for(int i=1; i<=n; i++)
            cin>>a[i]>>b[i],c[i]=m-a[i],d[i]=b[i],b[i]+=b[i-1];
        for(int i=n; i>=0; i--)
            d[i]+=d[i+1];
        for(int i=1; i<=n; i++)
            e[i]=max(e[i-1],b[i]-2*a[i]),f[i]=max(f[i-1],b[i]-a[i]);
        long long ans=0;
        for(int i=1; i<=n+1; i++)
            ans=max(ans,max(e[i-1]+d[i]-c[i],f[i-1]+d[i]-2*c[i]));
        cout<<ans;
        return 0;
    }
  • 相关阅读:
    学JAVA第十一天,属性与方法
    学JAVA第十天,一维数组及二维数组的使用。
    限制input[type=number]的输入位数策略整理
    淘宝NPM源的使用
    webpack之loader实践
    5月份开发问题整理
    前后端分离思考
    js 导航栏多项点击显示下拉菜单代码
    阵容首发
    jquery中的ajax请求到php(学生笔记)
  • 原文地址:https://www.cnblogs.com/BobHuang/p/8910519.html
Copyright © 2011-2022 走看看