zoukankan      html  css  js  c++  java
  • 数据结构实验之排序三:bucket sort

                                                                            数据结构实验之排序三:bucket sort

    Time Limit: 150MS Memory Limit: 65536KB

    Problem Description

    根据人口普查结果,知道目前淄博市大约500万人口,你的任务是帮助人口普查办公室按年龄递增的顺序输出每个年龄有多少人,其中不满1周岁的按0岁计算,1到2周岁的按1岁计算,依次类推,大于等于100岁的老人全部按100岁计算。

    Input

     输入第一行给出一个正整数N(<=5000000),随后连续给出N个整数表示每个人的年龄,数字间以空格分隔。

    Output

     按年龄递增的顺序输出每个年龄的人口数,人口数为0的不输出,每个年龄占一行,数字间以一个空格分隔,行末不得有多余空格或空行。

    Example Input

    10
    16 71 17 16 18 18 19 18 19 20

    Example Output

    16 2
    17 1
    18 3
    19 2
    20 1
    71 1
    

    #include <stdio.h>
    int main()
    {
    int n,i,a[123]={0};
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
    int t;
    scanf("%d",&t);
    if(t>100)
    a[100]++;
    else
    a[t]++;
    }
    for(i=0;i<=100;i++)
    {
    if(a[i])
    printf("%d %d\n",i,a[i]);
    }
    return 0;
    }

  • 相关阅读:
    poj2728 Desert King
    bzoj4289 Tax
    洛谷P4141消失之物
    Code Forces 698A Vacations
    Code Forces 543A Writing Code
    洛谷P1133 教主的花园
    poj3177 Redundant Paths
    bzoj1151 动物园
    bzoj1503 郁闷的出纳员
    bzoj1208 宠物收养所
  • 原文地址:https://www.cnblogs.com/CCCrunner/p/11782109.html
Copyright © 2011-2022 走看看