zoukankan      html  css  js  c++  java
  • POJ 3292 Semi-prime H-numbers


    类似素数筛。。。
    Semi-prime H-numbers
    Time Limit: 1000MSMemory Limit: 65536K
    Total Submissions: 6873Accepted: 2931

    Description

    This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of 4n+1 numbers. Here, we do only a bit of that.

    An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,... are the H-numbers. For this problem we pretend that these are the only numbers. The H-numbers are closed under multiplication.

    As with regular integers, we partition the H-numbers into units, H-primes, and H-composites. 1 is the only unit. An H-number h is H-prime if it is not the unit, and is the product of two H-numbers in only one way: 1 × h. The rest of the numbers are H-composite.

    For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.

    Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly two H-primes. The two H-primes may be equal or different. In the example above, all five numbers are H-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it's the product of three H-primes.

    Input

    Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.

    Output

    For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.

    Sample Input

    21
    85
    789
    0

    Sample Output

    21 0
    85 5
    789 62

    Source

    Waterloo Local Contest, 2006.9.30 



    #include <iostream>
    #include <cstdio>
    #include <cstring>

    using namespace std;

    const int MAXN=1000100;

    int H[MAXN],cnt[MAXN];

    void Init()
    {
        for(int i=1;i<MAXN;i+=4)
        {
            H=1;
            for(int j=5;j*j<=i;j+=4)
            {
                if(i%j==0)
                {
                    H=j;
                    break;
                }
            }
        }
        for(int i=5;i<MAXN;i+=4)
        {
            cnt=cnt[i-4];
            if(H!=1&&H[i/H]==1)
            {
                cnt++;
            }
        }
    }

    int main()
    {
        Init();
        int n;
        while(scanf("%d",&n)!=EOF&&n)
        {
            printf("%d %d ",n,cnt[n]);
        }
        return 0;
    }
    * This source code was highlighted by YcdoiT. ( style: Codeblocks )
  • 相关阅读:
    java第十三周作业
    java第十三周随堂
    安卓作业
    5.29 第十三周作业
    5.28第十三周上机练习
    5.22第十二周作业
    5.21第十二章上机练习
    5.15 第十一周作业
    5.14 第十一周 上机练习
    5.7第十周上机练习
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350810.html
Copyright © 2011-2022 走看看