zoukankan      html  css  js  c++  java
  • POJ 1496 Word Index


    组合数学。。。。和上一题是一样的。。。。
    Word Index
    Time Limit: 1000MSMemory Limit: 10000K
    Total Submissions: 4303Accepted: 2439

    Description

    Encoding schemes are often used in situations requiring encryption or information storage/transmission economy. Here, we develop a simple encoding scheme that encodes particular types of words with five or fewer (lower case) letters as integers. 

    Consider the English alphabet {a,b,c,...,z}. Using this alphabet, a set of valid words are to be formed that are in a strict lexicographic order. In this set of valid words, the successive letters of a word are in a strictly ascending order; that is, later letters in a valid word are always after previous letters with respect to their positions in the alphabet list {a,b,c,...,z}. For example, 

    abc aep gwz 

    are all valid three-letter words, whereas 

    aab are cat 

    are not. 

    For each valid word associate an integer which gives the position of the word in the alphabetized list of words. That is: 

    a -> 1
    b -> 2
    .
    .
    z -> 26
    ab -> 27
    ac -> 28
    .
    .
    az -> 51
    bc -> 52
    .
    .
    vwxyz -> 83681
    Your program is to read a series of input lines. Each input line will have a single word on it, that will be from one to five letters long. For each word read, if the word is invalid give the number 0. If the word read is valid, give the word's position index in the above alphabetical list. 

    Input

    The input consists of a series of single words, one per line. The words are at least one letter long and no more that five letters. Only the lower case alphabetic {a,b,...,z} characters will be used as input. The first letter of a word will appear as the first character on an input line. 

    The input will be terminated by end-of-file.

    Output

    The output is a single integer, greater than or equal to zero (0) and less than or equal 83681. The first digit of an output value should be the first character on a line. There is one line of output for each input line.

    Sample Input

    z
    a
    cat
    vwxyz

    Sample Output

    26
    1
    0
    83681

    Source

    East Central North America 1995 



    #include <iostream>
    #include <cstdio>
    #include <cstring>

    using namespace std;

    int c[30][30];
    char str[12];

    void Init()
    {
        for(int i=0;i<30;i++)
            c[0]=c=1;
        for(int i=2;i<30;i++)
            for(int j=1;j<i;j++)
                c[j]=c[i-1][j-1]+c[i-1][j];
    }

    int main()
    {
        Init();
        while(scanf("%s",str)!=EOF)
        {
            int len=strlen(str);
            bool flag=true;
            for(int i=0;i<len-1;i++)
            {
                if(str>=str[i+1])
                {
                    flag=false;
                    break;
                }
            }
            if(flag==false)
            {
                puts("0");
                continue;
            }
            ///n-1...1
            int sum=0;
            for(int i=1;i<len;i++)
                sum+=c[26];
            ///n
            for(int i=0;i<len;i++)
            {
                char ch=(i==0)?'a':str[i-1]+1;
                while(ch<str)
                {
                    sum+=c['z'-ch][len-1-i];
                    ch++;
                }
            }
            printf("%d ",++sum);
        }
        return 0;
    }
    * This source code was highlighted by YcdoiT. ( style: Codeblocks )

  • 相关阅读:
    Leecode刷题之旅-C语言/python-67二进制求和
    maven 聚合
    maven 继承
    maven 常用命令
    maven 术语
    maven安装
    RabbitMQ 消费消息
    RabbitMQ 生产消息并放入队列
    RabbitMQ 在 web 页面 创建 exchange, queue, routing key
    mybatis 通过实体类进行查询
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350814.html
Copyright © 2011-2022 走看看