zoukankan      html  css  js  c++  java
  • POJ 1850 Code

    组合数学。。。。


    Code
    Time Limit: 1000MSMemory Limit: 30000K
    Total Submissions: 7202Accepted: 3361

    Description

    Transmitting and memorizing information is a task that requires different coding systems for the best use of the available space. A well known system is that one where a number is associated to a character sequence. It is considered that the words are made only of small characters of the English alphabet a,b,c, ..., z (26 characters). From all these words we consider only those whose letters are in lexigraphical order (each character is smaller than the next character). 

    The coding system works like this: 
    The words are arranged in the increasing order of their length. 
    The words with the same length are arranged in lexicographical order (the order from the dictionary). 
    We codify these words by their numbering, starting with a, as follows: 
    a - 1 
    b - 2 
    ... 
    z - 26 
    ab - 27 
    ... 
    az - 51 
    bc - 52 
    ... 
    vwxyz - 83681 
    ... 

    Specify for a given word if it can be codified according to this coding system. For the affirmative case specify its code. 

    Input

    The only line contains a word. There are some constraints: 
    The word is maximum 10 letters length 
    The English alphabet has 26 characters. 

    Output

    The output will contain the code of the given word, or 0 if the word can not be codified.

    Sample Input

    bf

    Sample Output

    55

    Source

    Romania OI 2002 

    主要是这个公式。。。

    POJ 1850 Code - qhn999 - 码代码的猿猿

      然后就是关键了,长度为2的字符串,根据开头字母不同,就有25种不同情况,编程去处理是很困难的。这里必须要用数学方法去处理。

    POJ 1850 Code - qhn999 - 码代码的猿猿


    POJ 1850 Code - qhn999 - 码代码的猿猿

    所以用一个简单的循环就能计算出 比str长度少的所有字符串个数 了,这就是数学的威力,把受限的取法转换为不限制的取法



    #include <iostream>
    #include <cstdio>
    #include <cstring>

    using namespace std;

    int c[30][30];
    char str[30];

    void Init()
    {
        for(int i=0;i<30;i++)
            c[0]=c=1;
        for(int i=2;i<30;i++)
            for(int j=1;j<i;j++)
                c[j]=c[i-1][j-1]+c[i-1][j];
    }

    int main()
    {
        Init();
        while(scanf("%s",str)!=EOF)
        {
            bool flag=true;
            int len=strlen(str);
            for(int i=0;i<len-1;i++)
            {
                if(str>=str[i+1])
                {
                    flag=false;
                    break;
                }
            }
            if(!flag) { printf("0 ");continue; }

            int sum=0;
            ///n-1...1
            for(int i=1;i<len;i++)
            {
                sum+=c[26];
            }
            ///N
            for(int i=0;i<len;i++)
            {
                char ch=(i==0)?'a':str[i-1]+1;
                while(ch<str)
                {
                    sum+=c['z'-ch][len-1-i];
                    ch++;
                }
            }
            printf("%d ",++sum);
        }
        return 0;
    }
    * This source code was highlighted by YcdoiT. ( style: Codeblocks )
  • 相关阅读:
    201671030116宋菲菲 实验三作业互评与改进报告
    通读《构建之法》提出问题
    201671010460-朱艺璇-实验四附加实验
    201671010460朱艺璇 词频统计软件项目报告
    201671010460朱艺璇 实验三作业互评与改进报告
    阅读《现代软件工程—构建之法》提出的问题
    手把手带你了解消息中间件(3)——RocketMQ
    字符编码的历史由来
    linux常用命令
    linux各目录及重要目录的详细介绍
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350815.html
Copyright © 2011-2022 走看看