zoukankan      html  css  js  c++  java
  • POJ 3252 Round Numbers


     组合数学。。。(每做一题都是这么艰难)
    Round Numbers
    Time Limit: 2000MSMemory Limit: 65536K
    Total Submissions: 7607Accepted: 2615

    Description

    The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

    They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
    otherwise the second cow wins.

    A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

    Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

    Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

    Input

    Line 1: Two space-separated integers, respectively Start and Finish.

    Output

    Line 1: A single integer that is the count of round numbers in the inclusive range Start..Finish

    Sample Input

    2 12

    Sample Output

    6

    Source

    USACO 2006 November Silver 



    #include <iostream>
    #include <cstdio>
    #include <cstring>

    using namespace std;

    int c[35][35],bit[35];

    void Init()
    {
        for(int i=0;i<=33;i++)
            c=c[0]=1;
        for(int i=2;i<=33;i++)
            for(int j=1;j<i;j++)
                c[j]=c[i-1][j-1]+c[i-1][j];
    }

    int calu(int x)
    {
        if(x<=1return 0;
        memset(bit,0,sizeof(bit));
        int pos=32,ret=0;
        for(int i=0;i<32;i++)
            if(x&(1<<i)) bit=1;
        for(;bit[pos]==0&&pos>=0;pos--);
        ///n-1....1
        for(int i=pos;i>=1;i--)
        {
            int k=i-1;
            if(i%2)
                ret+=((1<<k)-c[k][k>>1])>>1;
            else
                ret+=(1<<k)>>1;
        }
        ///N
        int n1=0,n0=0;
        for(int i=pos;i>=0;i--)
        {
            if(bit) n1++;
            else n0++;
        }
        if(n0>=n1) ret++;
        n1=1,n0=0;
        for(int i=pos-1;i>=0;i--)
        {
            if(bit)
            {
                for(int j=i;j>=0&&n0+j+1>=n1+i-j;j--)
                {
                    ret+=c[j];
                }
                n1++;
            }
            else n0++;
        }
        return ret;
    }

    int main()
    {
        Init();
        int a,b;
        while(scanf("%d%d",&a,&b)!=EOF)
        {
            printf("%d ",calu(b)-calu(a-1));
        }
        return 0;
    }
    * This source code was highlighted by YcdoiT. ( style: Codeblocks )
  • 相关阅读:
    Linux操纵体系备份工具Tar运用说明
    Linux琐屑网络设置细致分解
    若何制造Linux系统启动盘2
    RedHatAS5下整合Apache和Tomcat
    移除Linux体系下不需求的效劳
    Linux平安隐患及增强管理的方法1
    Fedora 9 布置好后启动不克不及进入GUI,表现屏表现“Out Of Range"的处理惩罚法子
    Linux和Unix最常用的收集下令
    若何彻底移除编造机Wine模仿程式的图标
    若何制造Linux系统启动盘1
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350816.html
Copyright © 2011-2022 走看看