zoukankan      html  css  js  c++  java
  • HDOJ 4750 Count The Pairs



    按边长从小到大排序。。。
    再逐个加入(就像MST一样)最先联通的点之间最长路径中的最小值就是新加入的边的长。。。。

    Count The Pairs

    Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
    Total Submission(s): 266    Accepted Submission(s): 140


    Problem Description
    HDOJ 4750 Count The Pairs - qhn999 - 码代码的猿猿

      With the 60th anniversary celebration of Nanjing University of Science and Technology coming soon, the university sets n tourist spots to welcome guests. Of course, Redwood forests in our university and its Orychophragmus violaceus must be recommended as top ten tourist spots, probably the best of all. Some undirected roads are made to connect pairs of tourist spots. For example, from Redwood forests (suppose it’s a) to fountain plaza (suppose it’s b), there may exist an undirected road with its length c. By the way, there is m roads totally here. Accidently, these roads’ length is an integer, and all of them are different. Some of these spots can reach directly or indirectly to some other spots. For guests, they are travelling from tourist spot s to tourist spot t, they can achieve some value f. According to the statistics calculated and recorded by us in last years, We found a strange way to calculate the value f:
      From s to t, there may exist lots of different paths, guests will try every one of them. One particular path is consisted of some undirected roads. When they are travelling in this path, they will try to remember the value of longest road in this path. In the end, guests will remember too many longest roads’ value, so he cannot catch them all. But, one thing which guests will keep it in mind is that the minimal number of all these longest values. And value f is exactly the same with the minimal number.
      Tom200 will recommend pairs (s, t) (start spot, end spot points pair) to guests. P guests will come to visit our university, and every one of them has a requirement for value f, satisfying f>=t. Tom200 needs your help. For each requirement, how many pairs (s, t) you can offer?
     

    Input
      Multiple cases, end with EOF.
      First line:n m
      n tourist spots ( 1<n<=10000), spots’ index starts from 0.
      m undirected roads ( 1<m<=500000).

      Next m lines, 3 integers, a b c
      From tourist spot a to tourist spot b, its length is c. 0<a, b<n, c(0<c<1000000000), all c are different.

      Next one line, 1 integer, p (0<p<=100000)
      It means p guests coming.

      Next p line, each line one integer, t(0<=t)
      The value t you need to consider to satisfy f>=t.
     

    Output
      For each guest's requirement value t, output the number of pairs satisfying f>=t.
      Notice, (1,2), (2,1) are different pairs.
     

    Sample Input
    2 1
    0 1 2
    3
    1
    2
    3
    3 3
    0 1 2
    0 2 4
    1 2 5
    5
    0
    2
    3
    4
    5
     

    Sample Output
    2
    2
    0
    6
    6
    4
    4
    0
     

    Source
     

    Recommend
    liuyiding
     
     



    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>

    using namespace std;

    struct Edge
    {
        int s,t,len;
    }E[550000];
    int n,m,p,ar[550000],sum[550000];

    bool cmp(Edge a,Edge b)
    {
        return a.len<b.len;
    }

    int father[550000],ran[550000];

    void Init()
    {
        for(int i=0;i<n+10;i++)
        {
            father=i;
            ran=1;
        }
    }

    int Find(int x)
    {
        if(x==father[x]) return x;
        else return  father[father[x]]=Find(father[x]);
    }

    int Union(int a,int b)
    {
        int fa=Find(a),fb=Find(b);
        if(fa==fb) return 0;
        if(ran[fa]<=ran[fb])
        {
            father[fa]=fb;
            int x=ran[fb];
            ran[fb]+=ran[fa];
            return ran[fa]*x;
        }
        else
        {
            father[fb]=fa;
            int x=ran[fa];
            ran[fa]+=ran[fb];
            return ran[fb]*x;
        }
    }

    int main()
    {
        while(scanf("%d%d",&n,&m)!=EOF)
        {
            for(int i=0;i<m;i++)
            {
                scanf("%d%d%d",&E.s,&E.t,&E.len);
            }
            sort(E,E+m,cmp);
            Init();
            for(int i=0;i<m;i++)
            {
                ar=E.len;
                int S=E.s,T=E.t;
                if(i==0)
                    sum=Union(S,T);
                else
                    sum=sum[i-1]+Union(S,T);
               // printf("NO.%d     %d: %d ",i,ar,sum);
            }
            scanf("%d",&p);
            while(p--)
            {
                int q;
                scanf("%d",&q);
                int t=lower_bound(ar,ar+m,q)-ar;
              //  cout<<"......"<<t<<endl;
                printf("%d ",(sum[m-1]-sum[t-1])*2);
            }
        }
        return 0;
    }
    * This source code was highlighted by YcdoiT. ( style: Codeblocks )

  • 相关阅读:
    IDEA 2020.1 使用eclipse快捷键
    IDEA 2020.1 配置自定义Maven
    Maven 下载、安装、设置国内镜像
    IDEA 2020.1 下载、安装、激活
    MySQL 5.5/5.7 zip版 下载、安装、卸载、报错
    JDK8 下载、安装、配置环境变量
    如何在虚拟机VM15中安装W10
    虚拟机的安装,VMware-workstation-full-15.5.1-15018445
    为什么要买云服务器
    输入子系统实现的按键驱动
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350834.html
Copyright © 2011-2022 走看看