zoukankan      html  css  js  c++  java
  • POJ 3267 The Cow Lexicon

    又见面了,还是原来的配方,还是熟悉的DP。。。。直接秒了。。。
    The Cow Lexicon
    Time Limit: 2000MSMemory Limit: 65536K
    Total Submissions: 7316Accepted: 3421

    Description

    Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters 'a'..'z'. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

    The cows want you to help them decipher a received message (also containing only characters in the range 'a'..'z') of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

    Input

    Line 1: Two space-separated integers, respectively: W and L 
    Line 2: L characters (followed by a newline, of course): the received message 
    Lines 3..W+2: The cows' dictionary, one word per line

    Output

    Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.

    Sample Input

    6 10
    browndcodw
    cow
    milk
    white
    black
    brown
    farmer

    Sample Output

    2

    Source

    USACO 2007 February Silver 



    #include <iostream>
    #include <cstdio>
    #include <cstring>

    using namespace std;

    int n,m;
    char wen[500];
    int dp[500];

    struct dict
    {
        char word[100];
        char theLastLaw;
        int len;
    }D[800];

    int main()
    {
        scanf("%d%d",&n,&m);
        getchar();
        for(int i=1;i<=m;i++)
        {
            scanf("%c",&wen);
        }
        for(int i=0;i<n;i++)
        {
            scanf("%s",D.word);
            D.len=strlen(D.word);
            D.theLastLaw=D.word[D.len-1];
        }
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=m;i++)
        {
            dp=dp[i-1]+1;
            for(int j=0;j<n;j++)
            {
                if(wen==D[j].theLastLaw&&i>=D[j].len)
                {
               //     cout<<i<<": "<<wen<<" catch with: "<<D[j].word<<endl;
                    int flag=D[j].len-1,delet=0,pos=-1;
                    for(int k=i;k>0;k--)
                    {
                        if(wen[k]==D[j].word[flag])
                            flag--;
                        else
                            delet++;
                        if(flag<0){ pos=k; break;}
                    }
                 //   cout<<"the flag: "<<flag<<"  catch end with: "<<pos<<"  , delet is: "<<delet<<endl;
                    if(flag<0)
                    {
                        if(pos==-1) pos=0;
                        dp=min(dp,dp[pos-1]+delet);
                    }
                }
            }
        }
        printf("%d ",dp
    );
        return 0;
    }
    * This source code was highlighted by YcdoiT. ( style: Codeblocks )
  • 相关阅读:
    Java类、实例初始化的顺序
    Java中堆栈的区别
    int与Integer的区别(基本类型与复杂类型的对比)转
    JS中函数执行顺序的问题?
    springMVC --@RequestParam注解(后台控制器获取参数)
    如何安装request库
    流程图
    认识broken pipe
    postman动态使用url
    自定义一个List排序规则,然后对另一个List按照该规则排序
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350855.html
Copyright © 2011-2022 走看看