zoukankan      html  css  js  c++  java
  • HDOJ 1524 A Chess Game



    A Chess Game

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 1123    Accepted Submission(s): 519


    Problem Description
    Let's design a new chess game. There are N positions to hold M chesses in this game. Multiple chesses can be located in the same position. The positions are constituted as a topological graph, i.e. there are directed edges connecting some positions, and no cycle exists. Two players you and I move chesses alternately. In each turn the player should move only one chess from the current position to one of its out-positions along an edge. The game does not end, until one of the players cannot move chess any more. If you cannot move any chess in your turn, you lose. Otherwise, if the misfortune falls on me... I will disturb the chesses and play it again. 

    Do you want to challenge me? Just write your program to show your qualification!
     

    Input
    Input contains multiple test cases. Each test case starts with a number N (1 <= N <= 1000) in one line. Then the following N lines describe the out-positions of each position. Each line starts with an integer Xi that is the number of out-positions for the position i. Then Xi integers following specify the out-positions. Positions are indexed from 0 to N-1. Then multiple queries follow. Each query occupies only one line. The line starts with a number M (1 <= M <= 10), and then come M integers, which are the initial positions of chesses. A line with number 0 ends the test case.
     

    Output
    There is one line for each query, which contains a string "WIN" or "LOSE". "WIN" means that the player taking the first turn can win the game according to a clever strategy; otherwise "LOSE" should be printed.
     

    Sample Input
    4
    2 1 2
    0
    1 3
    0
    1 0
    2 0 2
    0

    4
    1 1
    1 2
    0
    0
    2 0 1
    2 1 1
    3 0 1 3
    0

     

    Sample Output
    WIN
    WIN
    WIN
    LOSE
    WIN
     

    Source
     

    Recommend
    LL
     


     
    #include <iostream>
    #include <cstdio>
    #include <cstring>

    using namespace std;

    struct Edge
    {
        int to,next;
    }E[100000];

    int Size,Adj[1100];

    void Init()
    {
        Size=0;
        memset(Adj,-1,sizeof(Adj));
    }

    void Add_Edge(int u,int v)
    {
        E[Size].to=v;
        E[Size].next=Adj;
        Adj=Size++;
    }

    int SG[1100],N,n,m;

    int SG_dfs(int x)
    {
        if(SG[x]!=-1return SG[x];
        bool flag[1100];int i;
        memset(flag,false,sizeof(flag));
        for(i=Adj[x];~i;i=E.next)
        {
            SG_dfs(E.to);
            flag[SG[E.to]]=true;
        }
        for(i=0;i<N;i++)
        {
            if(!flagbreak;
        }
        return SG[x]=i;
    }

    int main()
    {
        while(scanf("%d",&N)!=EOF)
        {
            Init();
            for(int i=0;i<N;i++)
            {
                scanf("%d",&n);
                if(n==0continue;
                while(n--)
                {
                    int v;
                    scanf("%d",&v);
                    Add_Edge(i,v);
                }
            }
            memset(SG,-1,sizeof(SG));
            while(scanf("%d",&m)&&m)
            {
                int XOR=0;
                while(m--)
                {
                    int a;
                    scanf("%d",&a);
                    XOR^=SG_dfs(a);
                }
                if(XOR)
                    puts("WIN");
                else
                    puts("LOSE");
            }
        }
        return 0;
    }
    * This source code was highlighted by YcdoiT. ( style: Codeblocks )

  • 相关阅读:
    [转]HSPICE 使用流程
    [转]到底怎么样才叫看书?——上篇
    js弹出层
    mvc自定义扩展控件
    yield 关键字
    mvc学习地址
    C# 将List中的数据导入csv文件中
    Asp.net 下载文件(弹出对话框的形式)
    Asp.net中用Jquery实现Ajax回调后台方法
    SharePoint中获取当前登录的用户名
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350859.html
Copyright © 2011-2022 走看看