zoukankan      html  css  js  c++  java
  • HDOJ 1536 S-Nim


    S-Nim

    Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 3514    Accepted Submission(s): 1544


    Problem Description
    Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:


      The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.

      The players take turns chosing a heap and removing a positive number of beads from it.

      The first player not able to make a move, loses.


    Arthur and Caroll really enjoyed playing this simple game until they recently learned an easy way to always be able to find the best move:


      Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).

      If the xor-sum is 0, too bad, you will lose.

      Otherwise, move such that the xor-sum becomes 0. This is always possible.


    It is quite easy to convince oneself that this works. Consider these facts:

      The player that takes the last bead wins.

      After the winning player's last move the xor-sum will be 0.

      The xor-sum will change after every move.


    Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win. 

    Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove a number of beads in some predefined set S, e.g. if we have S =(2, 5) each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it? 

    your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position. This means, as expected, that a position with no legal moves is a losing position.
     

    Input
    Input consists of a number of test cases. For each test case: The first line contains a number k (0 < k ≤ 100 describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0 < m ≤ 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps. The last test case is followed by a 0 on a line of its own.
     

    Output
    For each position: If the described position is a winning position print a 'W'.If the described position is a losing position print an 'L'. Print a newline after each test case.
     

    Sample Input
    2 2 5
    3
    2 5 12
    3 2 4 7
    4 2 3 7 12
    5 1 2 3 4 5
    3
    2 5 12
    3 2 4 7
    4 2 3 7 12
    0
     

    Sample Output
    LWW
    WWL
     

    Source
     

    Recommend
    LL
     
     
    人生中第一道SG函数题。。。。。

    SG_DFS:

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>

    using namespace std;

    int k,s[111],t,m,a;
    int sg[11000];

    int SG_dfs(int x)
    {
        if(sg[x]!=-1)
        {
            return sg[x];
        }
        int i;bool vis[111];
        memset(vis,false,sizeof(vis));
        for(i=0;s<=x&&i<k;i++)
        {
            SG_dfs(x-s);
            vis[sg[x-s]]=true;
        }
        for(i=0;i<=10000;i++)
        {
            if(!visbreak;
        }
        return sg[x]=i;
    }

    int main()
    {
        while(scanf("%d",&k)!=EOF&&k)
        {
            for(int i=0;i<k;i++)
                scanf("%d",s+i);
            sort(s,s+k);
            memset(sg,-1,sizeof(sg));
            scanf("%d",&t);
            while(t--)
            {
                scanf("%d",&m);
                int XOR=0;
                while(m--)
                {
                    scanf("%d",&a);
                    XOR^=SG_dfs(a);
                }
                printf("%c",XOR?'W':'L');
            }
            putchar(10);
        }
        return 0;
    }
    * This source code was highlighted by YcdoiT. ( style: Codeblocks )


    SG打表:

    #include <iostream>
    #include <cstdio>
    #include <cstring>

    using namespace std;

    int k,s[111],t,m,a;
    int sg[11000];

    void getSG()
    {
        memset(sg,0,sizeof(sg));
        bool flag[11000];
        for(int i=1;i<=10000;i++)
        {
            memset(flag,false,sizeof(flag));
            for(int j=0;j<k;j++)
            {
                if(s[j]>i) continue;
                flag[sg[i-s[j]]]=true;
            }
            for(int j=0;j<=10000;j++)
            {
                if(!flag[j])
                {
                    sg=j;break;
                }
            }
        }
    }

    int main()
    {
        while(scanf("%d",&k)!=EOF&&k)
        {
            for(int i=0;i<k;i++)
                scanf("%d",s+i);
            getSG();
            scanf("%d",&t);
            while(t--)
            {
                scanf("%d",&m);
                int XOR=0;
                while(m--)
                {
                    scanf("%d",&a);
                    XOR^=sg[a];
                }
                printf("%c",XOR?'W':'L');
            }
            putchar(10);
        }
        return 0;
    }
    * This source code was highlighted by YcdoiT. ( style: Codeblocks )

  • 相关阅读:
    C#字符串转换为数字的4种方法
    Linq to SQL Xml Based
    Code Snippets in Visual Studio 2010
    cygwin 压缩
    Cygwin安装Gitolite3
    ubuntu下如何用命令行运行deb安装包
    iconv bom
    __stdcall型dll转lib
    cygwin install lua modules
    luacom cygwin
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350862.html
Copyright © 2011-2022 走看看