zoukankan      html  css  js  c++  java
  • POJ 3253 Fence Repair



    Fence Repair
    Time Limit: 2000MSMemory Limit: 65536K
    Total Submissions: 20631Accepted: 6558

    Description

    Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

    FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

    Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

    Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

    Input

    Line 1: One integer N, the number of planks 
    Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

    Output

    Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

    Sample Input

    3
    8
    5
    8

    Sample Output

    34

    Hint

    He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
    The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

    Source

    USACO 2006 November Gold 

    霍夫曼树。。。。


    #include <iostream>
    #include <queue>
    #include <cstdio>
    #include <cstring>

    using namespace std;

    int main()
    {
        int n,a;
        long long int ans=0,sum=0;
        scanf("%d",&n);
        priority_queue< int,vector<int>,greater<int> > q;
        while(n--)
        {
            scanf("%d",&a);
            q.push(a);
            sum+=a;
        }
        while(q.size()>=2)
        {
            int i=q.top();
            q.pop();
            int j=q.top();
            q.pop();
            ans+=(i+j);
            q.push(i+j);
        }
        ans+=q.top();
        printf("%I64d ",ans-sum);
        return 0;
    }
    * This source code was highlighted by YcdoiT. ( style: Codeblocks )
  • 相关阅读:
    全体注意!一大波鸿蒙三方库已经到来!
    HarmonyOS三方件开发指南(18)-Flexbox流式布局组件
    002 使用鸿蒙WebView创建简单浏览器 step 2
    HarmonyOS开发者看过来,HDD上海站传递的重要信息都在这里
    别说不会微服务了,五分钟教你巧妙玩转分布式下链路追踪!
    五分钟教你如何优雅的统计代码耗时,让你知道你的程序到底慢在哪!
    腾讯元老赚够钱后辞职到安徽农村隐居,亲手建造200亩农场
    Python基础-19-元组
    Python基础-14-定义函数注意-调用函数
    Python基础-12-函数的参数
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350863.html
Copyright © 2011-2022 走看看