zoukankan      html  css  js  c++  java
  • Milking Cows



    Milking Cows

    Three farmers rise at 5 am each morning and head for the barn to milk three cows. The first farmer begins milking his cow at time 300 (measured in seconds after 5 am) and ends at time 1000. The second farmer begins at time 700 and ends at time 1200. The third farmer begins at time 1500 and ends at time 2100. The longest continuous time during which at least one farmer was milking a cow was 900 seconds (from 300 to 1200). The longest time no milking was done, between the beginning and the ending of all milking, was 300 seconds (1500 minus 1200).

    Your job is to write a program that will examine a list of beginning and ending times for N (1 <= N <= 5000) farmers milking N cows and compute (in seconds):

    • The longest time interval at least one cow was milked.
    • The longest time interval (after milking starts) during which no cows were being milked.

    PROGRAM NAME: milk2

    INPUT FORMAT

    Line 1:The single integer
    Lines 2..N+1:Two non-negative integers less than 1000000, the starting and ending time in seconds after 0500

    SAMPLE INPUT (file milk2.in)

    3
    300 1000
    700 1200
    1500 2100

    OUTPUT FORMAT

    A single line with two integers that represent the longest continuous time of milking and the longest idle time.

    SAMPLE OUTPUT (file milk2.out)

    900 300 


    /*
        ID:qhn9992
        PROG:milk2
        LANG:C++
    */

    #include <iostream>
    #include <cstdio>
    #include <cstring>

    using namespace std;

    int ran[1000010],a,b,t,st=0,milking,idle,ans1,ans2;

    int main()
    {
        freopen("milk2.in","r",stdin);
        freopen("milk2.out","w",stdout);

        cin>>t;int start=999999999,end=-99999999;
        memset(ran,0,sizeof(ran));
        while(t--)
        {
            cin>>a>>b;
            start=min(a,start);
            end=max(end,b);
            ran[a]+=1;
            ran+=-1;
        }
        st=milking=idle=0;
        ans1=ans2=-9999;
        bool work=false;
        for(int i=start;i<=end;i++)
        {
            st+=ran;
            if(st==0)
            {
                if(work==true)
                {
                    work=false;
                    ans1=max(ans1,milking);
                    milking=0;
                }
                idle++;
            }
            else
            {
                if(work==false)
                {
                    work=true;
                    ans2=max(ans2,idle);
                    idle=0;
                }
                milking++;
            }
        }
        cout<<ans1<<" "<<ans2<<endl;
        return 0;
    }
    * This source code was highlighted by YcdoiT. ( style: Codeblocks )


  • 相关阅读:
    经典面试题之——如何自由转换两个没有继承关系的字段及类型相同的实体模型,AutoMapper?
    MySQL高效分页-mybatis插件PageHelper改进
    bat/cmd批处理程序设计教程
    除法与模运算的识别-大量除法推导过程
    进程 线程 协程的相关理解
    音素音标
    如何免费的让网站启用HTTPS
    破解笔记
    Linux的.a、.so和.o文件 对比 window下的dll,lib,exe文件
    注册表启动的位置
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350872.html
Copyright © 2011-2022 走看看