zoukankan      html  css  js  c++  java
  • POJ 3041 Asteroids

     
    最小点覆盖数==最大匹配数
    Asteroids
    Time Limit: 1000MSMemory Limit: 65536K
    Total Submissions: 12678Accepted: 6904

    Description

    Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

    Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

    Input

    * Line 1: Two integers N and K, separated by a single space. 
    * Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

    Output

    * Line 1: The integer representing the minimum number of times Bessie must shoot.

    Sample Input

    3 4
    1 1
    1 3
    2 2
    3 2

    Sample Output

    2

    Hint

    INPUT DETAILS: 
    The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
    X.X 
    .X. 
    .X.
     

    OUTPUT DETAILS: 
    Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

    Source



    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <vector>

    using namespace std;

    int N,P,from[1000];
    vector<int> g[1000];
    bool use[1000];

    bool match(int u)
    {
        for(int i=0;i<g.size();i++)
        {
            if(!use[g])
            {
                use[g]=true;
                if(!from[g]||match(from[g]))
                {
                    from[g]=u;
                    return true;
                }
            }
        }
        return false;
    }

    int hungary()
    {
        int ret=0;
        memset(from,0,sizeof(from));
        for(int i=1;i<=N;i++)
        {
            memset(use,0,sizeof(use));
            if(match(i)) ret++;
        }
        return ret;
    }

    int main()
    {
        while(scanf("%d%d",&N,&P)!=EOF)
        {
            memset(g,0,sizeof(g));
            for(int i=1;i<=P;i++)
            {
                int a,b;
                scanf("%d%d",&a,&b);
                g[a].push_back(b);
            }
            printf("%d ",hungary());
        }
        return 0;
    }
    * This source code was highlighted by YcdoiT. ( style: Vs )

  • 相关阅读:
    常规排序算法 : 冒泡排序
    console.log(([])?true:false); console.log(([]==false?true:false)); console.log(({}==false)?true:false)
    近况
    正向代理和反向代理
    Angular项目目录结构
    模块化Vs组件化
    模块化开发——高内聚低耦合
    20190608笔试题のCSS-属性继承
    20190527-JavaScriptの打怪升级旅行 { 语句 [ 声明 ,变量 ] }
    20190430-Bootstrapの组件
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350873.html
Copyright © 2011-2022 走看看