zoukankan      html  css  js  c++  java
  • HDOJ 2389 Rain on your Parade

     
    HK。。。。

    Rain on your Parade

    Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 655350/165535 K (Java/Others)
    Total Submission(s): 2229    Accepted Submission(s): 696


    Problem Description
    You’re giving a party in the garden of your villa by the sea. The party is a huge success, and everyone is here. It’s a warm, sunny evening, and a soothing wind sends fresh, salty air from the sea. The evening is progressing just as you had imagined. It could be the perfect end of a beautiful day.
    But nothing ever is perfect. One of your guests works in weather forecasting. He suddenly yells, “I know that breeze! It means its going to rain heavily in just a few minutes!” Your guests all wear their best dresses and really would not like to get wet, hence they stand terrified when hearing the bad news.
    You have prepared a few umbrellas which can protect a few of your guests. The umbrellas are small, and since your guests are all slightly snobbish, no guest will share an umbrella with other guests. The umbrellas are spread across your (gigantic) garden, just like your guests. To complicate matters even more, some of your guests can’t run as fast as the others.
    Can you help your guests so that as many as possible find an umbrella before it starts to pour? 

    Given the positions and speeds of all your guests, the positions of the umbrellas, and the time until it starts to rain, find out how many of your guests can at most reach an umbrella. Two guests do not want to share an umbrella, however. 
     

    Input
    The input starts with a line containing a single integer, the number of test cases.
    Each test case starts with a line containing the time t in minutes until it will start to rain (1 <=t <= 5). The next line contains the number of guests m (1 <= m <= 3000), followed by m lines containing x- and y-coordinates as well as the speed si in units per minute (1 <= si <= 3000) of the guest as integers, separated by spaces. After the guests, a single line contains n (1 <= n <= 3000), the number of umbrellas, followed by n lines containing the integer coordinates of each umbrella, separated by a space.
    The absolute value of all coordinates is less than 10000.
     

    Output
    For each test case, write a line containing “Scenario #i:”, where i is the number of the test case starting at 1. Then, write a single line that contains the number of guests that can at most reach an umbrella before it starts to rain. Terminate every test case with a blank line.
     

    Sample Input
    2
    1
    2
    1 0 3
    3 0 3
    2
    4 0
    6 0
    1
    2
    1 1 2
    3 3 2
    2
    2 2
    4 4
     

    Sample Output
    Scenario #1:
    2

    Scenario #2:
    2 
     

    Source
     

    Recommend
    lcy
     



    #include <iostream>
    #include <cstdio>
    #include <vector>
    #include <queue>
    #include <cstring>

    using namespace std;

    vector<int> g[4000];
    struct node
    {
        int x,y,s;
    }PEO[4000];
    int mx[4000],my[4000],n1,n2,dx[4000],dy[4000];
    bool use[4000];

    bool find(int u)
    {
        for(int i=0;i<g.size();i++)
        {
            int v=g;
            if(!use[v]&&dy[v]==dx+1)
            {
                use[v]=true;
                if(!my[v]||find(my[v]))
                {
                    mx=v;
                    my[v]=u;
                    return true;
                }
            }
        }
        return false;
    }

    int HKmatch()
    {
        memset(mx,0,sizeof(mx));
        memset(my,0,sizeof(my));
        int ans=0;
        while(true)
        {
            bool flag=false;
            queue<int> q;
            memset(dx,0,sizeof(dx));
            memset(dy,0,sizeof(dy));
            for(int i=1;i<=n1;i++)
            {
                if(!mx) q.push(i);
            }
            while(!q.empty())
            {
                int u=q.front(); q.pop();
                for(int i=0;i<g.size();i++)
                {
                    int v=g;
                    if(!dy[v])
                    {
                        dy[v]=dx+1;
                        if(my[v])
                        {
                            dx[my[v]]=dy[v]+1;
                            q.push(my[v]);
                        }
                        else flag=true;
                    }
                }
            }
            if(!flag) break;
            memset(use,0,sizeof(use));
            for(int i=1;i<=n1;i++)
                if(!mx&&find(i))
                     ans++;
        }
        return ans;
    }

    int main()
    {
        int T,cas=1;
        scanf("%d",&T);
        while(T--)
        {
            memset(g,0,sizeof(g));
            int time;
            scanf("%d",&time);
            scanf("%d",&n1);
            for(int i=1;i<=n1;i++)
            {
                int x,y,s;
                scanf("%d%d%d",&x,&y,&s);
                PEO.x=x;PEO.y=y;PEO.s=s;
            }
            scanf("%d",&n2);
            for(int i=1;i<=n2;i++)
            {
                int x,y;
                scanf("%d%d",&x,&y);
                for(int j=1;j<=n1;j++)
                {
                    int dist1=(PEO[j].x-x)*(PEO[j].x-x)+(PEO[j].y-y)*(PEO[j].y-y);
                    int dist2=(PEO[j].s*time)*(PEO[j].s*time);
                    if(dist2>=dist1)
                    {
                       // cout<<j<<"---->"<<i<<endl;
                        g[j].push_back(i);
                    }
                }
            }
            printf("Scenario #%d: %d ",cas++,HKmatch());
        }
    }
    * This source code was highlighted by YcdoiT. ( style: Codeblocks )
  • 相关阅读:
    Python any()
    从 SQL Server 到 MySQL (一):异构数据库迁移
    sql server作业实现数据同步
    分布式异构系统的数据一致性架构实现
    实战:sqlserver 数据实时同步到mysql
    基于MySQL的高可用准实时的数据同步方案
    SQL Server数据同步的研究(单向/双向)
    YY 数据库平台化建设实践
    两台SqlServer数据同步解决方案
    热迁移、异构数据库迁移、传输性能 这些上云的难题阿里云都帮你解决了
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350875.html
Copyright © 2011-2022 走看看