zoukankan      html  css  js  c++  java
  • HDOJ 1083 Courses


    Hopcroft-Karp算法模板

    Courses

    Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 2930    Accepted Submission(s): 1376


    Problem Description
    Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

    . every student in the committee represents a different course (a student can represent a course if he/she visits that course)

    . each course has a representative in the committee

    Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format:

    P N
    Count1 Student1 1 Student1 2 ... Student1 Count1
    Count2 Student2 1 Student2 2 ... Student2 Count2
    ...... 
    CountP StudentP 1 StudentP 2 ... StudentP CountP

    The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you'll find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

    There are no blank lines between consecutive sets of data. Input data are correct.

    The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

    An example of program input and output:
     

    Sample Input
    2
    3 3
    3 1 2 3
    2 1 2
    1 1
    3 3
    2 1 3
    2 1 3
    1 1
     

    Sample Output
    YES
    NO
     

    Source
      



    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <vector>
    #include <queue>

    using namespace std;

    const int MAXN=4000;
    vector<int> g[MAXN];
    int mx[MAXN],my[MAXN],dx[MAXN],dy[MAXN],n1,n2;
    bool use[MAXN];

    bool find(int u)
    {
        for(int i=0;i<g.size();i++)
        {
            if(!use[g]&&dy[g]==dx+1)
            {
                use[g]=true;
                if(!my[g]||find(my[g]))
                {
                    mx=g;
                    my[g]=u;
                    return true;
                }
            }
        }
        return false;
    }

    int HKmatch()
    {
        memset(mx,0,sizeof(mx));
        memset(my,0,sizeof(my));
        int ans=0;
        while(true)
        {
            bool flag=false;
            queue<int> q;
            memset(dx,0,sizeof(dx));
            memset(dy,0,sizeof(dy));
            for(int i=1;i<=n1;i++)
            {
                if(!mx) q.push(i);
            }
            while(!q.empty())
            {
                int u=q.front(); q.pop();
                for(int i=0;i<g.size();i++)
                {
                    if(!dy[g])
                    {
                        dy[g]=dx+1;
                        if(my[g])
                        {
                            dx[my[g]]=dy[g]+1;
                            q.push(my[g]);
                        }
                        else  flag=true;
                    }
                }
            }
            if(!flag) break;
            memset(use,false,sizeof(use));
            for(int i=1;i<=n1;i++)
                if(!mx&&find(i)) ans++;
        }
        return ans;
    }

    int main()
    {
        int T;
        scanf("%d",&T);
        while(T--)
        {
            memset(g,0,sizeof(g));
            scanf("%d%d",&n1,&n2);
            for(int i=1;i<=n1;i++)
            {
                int m; scanf("%d",&m);
                for(int j=0;j<m;j++)
                {
                    int x;
                    scanf("%d",&x);
                    g.push_back(x);
                }
            }
            if(HKmatch()==n1) puts("YES");
            else puts("NO");
        }

        return 0;
    }
    * This source code was highlighted by YcdoiT. ( style: Codeblocks )


  • 相关阅读:
    【已解决】ERR_BLOCKED_BY_XSS_AUDITOR:Chrome 在此网页上检测到了异常代码:解决办法
    【已解决】Microsoft visual c++ 14.0 is required问题解决办法
    爬虫处理网站的bug---小于号未转化为实体符
    pymysql 在数据库中插入空值
    python 正则括号的使用及踩坑
    pymysql 解决 sql 注入问题
    python3 操作MYSQL实例及异常信息处理--用traceback模块
    LeetCode 837. 新21点 | Python
    LeetCode 面试题64. 求1+2+…+n | Python
    LeetCode 101. 对称二叉树 | Python
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350876.html
Copyright © 2011-2022 走看看