zoukankan      html  css  js  c++  java
  • POJ 2828 Buy Tickets

     传说中的传送门:http://poj.org/problem?id=2828  

    Buy Tickets
    Time Limit: 4000MSMemory Limit: 65536K
    Total Submissions: 10620Accepted: 5146

    Description

    Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

    The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

    It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

    People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

    Input

    There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Valiin the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

    • Posi ∈ [0, i ? 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
    • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

    There no blank lines between test cases. Proceed to the end of input.

    Output

    For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

    Sample Input

    4
    0 77
    1 51
    1 33
    2 69
    4
    0 20523
    1 19243
    1 3890
    0 31492

    Sample Output

    77 33 69 51
    31492 20523 3890 19243

    Hint

    The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

    POJ 2828 Buy Tickets - qhn999 - 码代码的猿猿

    Source





    从后往前插入,找到第pos个空位。。。。。用线段树维护空位数。。。。。。。。。


    #include <iostream>
    #include <cstdio>
    #include <cstring>

    using namespace std;

    #define lson l,m,rt<<1
    #define rson m+1,r,rt<<1|1

    const int MAXN=1111111;

    int sum[MAXN<<2];
    int ppt[MAXN<<2];
    void pushUP(int rt)
    {
        sum[rt]=sum[rt<<1]+sum[rt<<1|1];
    }

    void build(int l,int r,int rt)
    {
        if(l==r)
        {
            sum[rt]=1;
            return ;
        }
        int m=(l+r)>>1;
        build(lson); build(rson);
        pushUP(rt);
    }

    void print(int l,int r,int rt)
    {
        if(l==r)
        {
            printf("%d ",ppt[rt]);
            return ;
        }
        int m=(l+r)>>1;
        print(lson); print(rson);
    }

    void update(int pos,int num,int l,int r,int rt)
    {
        sum[rt]--;
        if(l==r)
        {
            ppt[rt]=num;
            return ;
        }
        int m=(l+r)>>1;
        if(pos<=sum[rt<<1])
            update(pos,num,lson);
        else if(pos>sum[rt<<1])
            update(pos-sum[rt<<1],num,rson);
    }

    int pos[202000],num[202000];
    int main()
    {
        int n;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&pos,&num);
            pos++;
        }
        build(1,n,1);
        for(int i=n-1;i>=0;i--)
            update(pos,num,1,n,1);
        print(1,n,1);
        putchar(10);
    }
        return 0;
    }



  • 相关阅读:
    mouse_event,keybd_event
    构造自己的StringGrid
    BMP2JPG,JPG2BMP
    $J的用法
    一个简单的系统托盘程序
    构造自己的双向链表
    C++的iostream标准库介绍
    D3DXVec4Dot 函数
    3D游戏从头编之D3D(3)
    D3DXVec4Cross 函数
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350912.html
Copyright © 2011-2022 走看看