zoukankan      html  css  js  c++  java
  • ZOJ 1872 Freckles



    Freckles

    Time Limit: 2 Seconds      Memory Limit: 65536 KB

    In an episode of the Dick Van Dyke show, little Richie connects the freckles on his Dad's back to form a picture of the Liberty Bell. Alas, one of the freckles turns out to be a scar, so his Ripley's engagement falls through. 

    Consider Dick's back to be a plane with freckles at various (x,y) locations. Your job is to tell Richie how to connect the dots so as to minimize the amount of ink used. Richie connects the dots by drawing straight lines between pairs, possibly lifting the pen between lines. When Richie is done there must be a sequence of connected lines from any freckle to any other freckle.


    Input

    The first line contains 0 < n <= 100, the number of freckles on Dick's back. For each freckle, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the freckle.

    Input contains multiple test cases. Process to the end of file.


    Output

    Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the freckles.


    Sample Input

    3
    1.0 1.0
    2.0 2.0
    2.0 4.0


    Sample Output

    3.41


    Source: University of Waterloo Local Contest 2000.09.23


    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <cmath>

    using namespace std;
    #define CLS(x,c) memset(x,c,sizeof(x))
    const int maxn=1111;
    int n;
    struct node
    {
        double x,y;
    }p[111];
    double gp[maxn][maxn];
    double distan(node a,node b)
    {
        return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
    }

    double prim(int n)
    {
        double lowcast[maxn];
        bool s[maxn];

        for(int i=1;i<=n;i++)
        {
            lowcast=distan(p[1],p);
            s=0;
        }

        s[1]=1;double sum=0;
        for(int i=2;i<=n;i++)
        {
            double minn=0x3f3f3f3f;
            int u=-1;
            for(int j=1;j<=n;j++)
            {
                if(!s[j]&&lowcast[j]<minn)
                {
                    minn=lowcast[j];
                    u=j;
                }
            }
            if(u==-1) return 0x3f3f3f3f;
            sum+=minn; s=1;

            for(int j=1;j<=n;j++)
            {
                if(!s[j]&&distan(p,p[j])<lowcast[j])
                    lowcast[j]=distan(p,p[j]);
            }
        }

        return sum;
    }

    int main()
    {
    while(scanf("%d",&n)!=EOF)
    {
        CLS(gp,0);
        for(int i=1;i<=n;i++)
        {
            scanf("%lf%lf",&p.x,&p.y);
        }
        printf("%.2lf ",prim(n));
    }
        return 0;
    }

  • 相关阅读:
    Cocos2d-x教程(26)-Cocos2d-x + Lua脚本实现大地图缩放功能
    【C语言】不使用大小于号,求出两数最大值
    软件project—思考项目开发那些事(一)
    linux下误删数据文件恢复
    C++中stringstream ostringstream istringstream使用方式
    谈谈c++纯虚函数的意义!
    CountDownTimer完整具体演示样例
    Flex 正則表達式 电话、邮箱验证
    DIV+CSS两种盒子模型(W3C盒子与IE盒子)
    图论--欧拉路,欧拉回路(小结)
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350923.html
Copyright © 2011-2022 走看看