zoukankan      html  css  js  c++  java
  • HDOJ 2639 Bone Collector II

    背包第K大。。。。。。。

    Bone Collector II

    Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 1448    Accepted Submission(s): 729


    Problem Description
    The title of this problem is familiar,isn't it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven't seen it before,it doesn't matter,I will give you a link:

    Here is the link:http://acm.hdu.edu.cn/showproblem.php?pid=2602

    Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum.

    If the total number of different values is less than K,just ouput 0.
     

    Input
    The first line contain a integer T , the number of cases.
    Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
     

    Output
    One integer per line representing the K-th maximum of the total value (this number will be less than 231).
     

    Sample Input
    3
    5 10 2
    1 2 3 4 5
    5 4 3 2 1
    5 10 12
    1 2 3 4 5
    5 4 3 2 1
    5 10 16
    1 2 3 4 5
    5 4 3 2 1
     

    Sample Output
    12
    2
    0
     

    Author
    teddy
     



    #include <iostream>
    #include <cstdio>
    #include <cstring>

    using namespace std;

    int n,V,K;
    int i,j,tt;
    int cost[200],weight[200],f[2000][40];
    int d[200],p[200];

    int main()
    {
        int T;
        cin>>T;
    while(T--)
    {
        cin>>n>>V>>K;

        memset(f,0,sizeof(f));
        memset(d,0,sizeof(d));
        memset(p,0,sizeof(p));

        for(i=1;i<=n;i++)
            cin>>weight;
        for(i=1;i<=n;i++)
            cin>>cost;

        for(i=1;i<=n;i++)
        {
            for(j=V;j>=cost;j--)
            {
                for(tt=1;tt<=K;tt++)
                {
                    d[tt]=f[j][tt];
                    p[tt]=f[j-cost][tt]+weight;
                }

                d[tt]=-1;
                p[tt]=-1;

                int x,y,z;
                x=y=z=1;

                while(z<=K&&(x<=K||y<=K))
                {
                    if(d[x]>p[y])
                        f[j][z]=d[x++];
                    else
                        f[j][z]=p[y++];
                    if(f[j][z]!=f[j][z-1])
                        z++;
                }

            }
        }

        cout<<f[V][K]<<endl;
    }

        return 0;
    }

  • 相关阅读:
    进程和线程(一)
    树和二叉树(一)
    栈和队列
    《Learning to Coordinate with Coordination Graphs in Repeated Single-Stage Multi-Agent Decision Problems》- ICML2018
    简单Socket网络通信
    Spring Websocket实现简易在线聊天功能
    Spring实现WebSocket通信
    Spring中配置使用slf4j + log4j
    构建web应用之——文件上传
    构建web应用之——SpringMVC实现CRUD
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350951.html
Copyright © 2011-2022 走看看