zoukankan      html  css  js  c++  java
  • POJ 1323 Game Prediction (贪心)



    Game Prediction
    Time Limit: 1000MSMemory Limit: 10000K
    Total Submissions: 8866Accepted: 4225

    Description

    Suppose there are M people, including you, playing a special card game. At the beginning, each player receives N cards. The pip of a card is a positive integer which is at most N*M. And there are no two cards with the same pip. During a round, each player chooses one card to compare with others. The player whose card with the biggest pip wins the round, and then the next round begins. After N rounds, when all the cards of each player have been chosen, the player who has won the most rounds is the winner of the game. 



    Given your cards received at the beginning, write a program to tell the maximal number of rounds that you may at least win during the whole game. 

    Input

    The input consists of several test cases. The first line of each case contains two integers m (2?20) and n (1?50), representing the number of players and the number of cards each player receives at the beginning of the game, respectively. This followed by a line with n positive integers, representing the pips of cards you received at the beginning. Then a blank line follows to separate the cases. 

    The input is terminated by a line with two zeros. 

    Output

    For each test case, output a line consisting of the test case number followed by the number of rounds you will at least win during the game. 

    Sample Input

    2 5
    1 7 2 10 9

    6 11
    62 63 54 66 65 61 57 56 50 53 48

    0 0

    Sample Output

    Case 1: 2
    Case 2: 4

    Source




    #include <iostream>
    #include <cstdio>
    #include <cstring>

    using namespace std;

    int a[20000];

    int main()
    {
    int n,m;
    int cas=0;
    while(cin>>n>>m)
    {
        if(n==0&&m==0)
        {
            break;
        }
        memset(a,0,sizeof(a));
        int b;
        for(int i=0;i<m;i++)
        {
            cin>>b;
            a=2;
        }
        for(int i=1;i<=n*m;i++)
        {
            if(a==0)
            {
                a=1;
            }
        }

        int ans=0;
        int t=n-1;
        for(int i=n*m;i>0;i--)
        {
            t=n-1;
            if(a!=0)
            {
                if(a==2)
                {
                    ans++;
                    a=0;
                    int j=1;
                    while(t)
                    {
                        if(a[j]==1)
                        {
                            a[j]=0;
                            t--;
                        }
                        j++;
                    }
                }
                else if(a==1)
                {
                    a=1;
                    for(int j=i;j>0;j--)
                    {
                        if(a[j]==2)
                        {
                            a[j]=0;
                            break;
                        }
                    }
                    t--;
                    int j=1;
                    while(t)
                    {
                        if(a[j]==1)
                        {
                            a[j]=0;
                            t--;
                        }
                        j++;
                    }
                }
            }
        }

        printf("Case %d: %d ",++cas,ans);

    }
        return 0;
    }

  • 相关阅读:
    分布式事务
    幂等性
    方法重载
    伊人之乡
    恋桃诗
    C#使用litJson解析Json(二)
    C#使用litJson解析Json(一)
    用浏览器调试Html
    Oracle之触发器(Trigger)
    Oracle之视图(View)
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350989.html
Copyright © 2011-2022 走看看