zoukankan      html  css  js  c++  java
  • POJ 3258 River Hopscotch (binarysearch)


    River Hopscotch
    Time Limit: 2000MSMemory Limit: 65536K
    Total Submissions: 5193Accepted: 2260

    Description

    Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

    To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

    Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to rocks (0 ≤ M ≤ N).

    FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

    Input

    Line 1: Three space-separated integers: LN, and M 
    Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

    Output

    Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

    Sample Input

    25 5 2214112117

    Sample Output

    4

    Hint

    Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

    Source




    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>

    using namespace std;

    const int maxn=50050;
    int len,n,m;
    int a[maxn];

    int binarysearch(int low,int high)
    {
        int mid;
        while(low<=high)
        {
            mid=(low+high)/2;

            int s=0,e=1;
            int cnt=0;

            while(e<n)
            {
                if(a[e]-a[s]>=mid)
                {
                    s=e; e++;
                }
                else
                {
                    e++; cnt++;
                }
            }
    //cout<<low<<","<<mid<<","<<high<<endl;
    //cout<<"-->"<<cnt<<endl;
            if(cnt>m)
            {
                high=mid-1;
            }
            else
            {
                low=mid+1;
            }
        }
        return high;
    }

    int main()
    {
        cin>>len>>n>>m;
        for(int i=1;i<=n;i++)
            cin>>a;
        a[0]=0;
        a[n+1]=len;
        n=n+2;
        sort(a,a+n);
        int minn=len;
        for(int i=1;i<n;i++)
        {
            minn=min(minn,a-a[i-1]);
        }

        cout<<binarysearch(minn,len)<<endl;

        return 0;
    }

  • 相关阅读:
    m个苹果放入n个篮子
    C++ sort函数用法 C中的qsort
    C常见机试题
    二维数组作为函数参数的几种方法
    远程调用相关技术
    反射 与 序列化
    MFC 三种消息
    【2019.09.13】中秋快乐!来点福大猫咪色图ヽ(=^・ω・^=)丿
    【2019.09.11】用交互式思维导图展示学期规划(软件工程实践2019第二次作业)
    【2019.09.07】审视自我~(软件工程实践2019第一次作业)
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350994.html
Copyright © 2011-2022 走看看