zoukankan      html  css  js  c++  java
  • HDOJ 3177 Crixalis's Equipment


    Crixalis's Equipment

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 1854    Accepted Submission(s): 770


    Problem Description
    HDOJ 3177 Crixalis39;s Equipment - qhn999 - 码代码的猿猿Crixalis - Sand King used to be a giant scorpion(蝎子) in the deserts of Kalimdor. Though he's a guardian of Lich King now, he keeps the living habit of a scorpion like living underground and digging holes.

    Someday Crixalis decides to move to another nice place and build a new house for himself (Actually it's just a new hole). As he collected a lot of equipment, he needs to dig a hole beside his new house to store them. This hole has a volume of V units, and Crixalis has N equipment, each of them needs Ai units of space. When dragging his equipment into the hole, Crixalis finds that he needs more space to ensure everything is placed well. Actually, the ith equipment needs Bi units of space during the moving. More precisely Crixalis can not move equipment into the hole unless there are Bi units of space left. After it moved in, the volume of the hole will decrease by Ai. Crixalis wonders if he can move all his equipment into the new hole and he turns to you for help.
     

    Input
    The first line contains an integer T, indicating the number of test cases. Then follows T cases, each one contains N + 1 lines. The first line contains 2 integers: V, volume of a hole and N, number of equipment respectively. The next N lines contain N pairs of integers: Ai and Bi.
    0<T<= 10, 0<V<10000, 0<N<1000, 0 <Ai< V, Ai <= Bi < 1000.
     

    Output
    For each case output "Yes" if Crixalis can move all his equipment into the new hole or else output "No".
     

    Sample Input
    2

    20 3
    10 20
    3 10
    1 7

    10 2
    1 10
    2 11
     

    Sample Output
    Yes
    No
     

    Source
     

    Recommend
    lcy
     


    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>

    using namespace std;

    struct Node
    {
        int a;
        int b;
        int c;
    }p[1111];

    bool cmp(Node x,Node y)
    {
        return x.c>=y.c;
    }

    int main()
    {
        int T;
        scanf("%d",&T);
    while(T--)
    {
        memset(p,0,sizeof(p));
        int n,v;
        scanf("%d%d",&v,&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&p.a,&p.b);
            p.c=p.b-p.a;
        }
        sort(p,p+n,cmp);

        int OK=1;
        for(int i=0;i<n;i++)
        {
            if(v>=p.b)
            {
                v-=p.a;
            }
            else
            {
                OK=0;
                break;
            }
        }

        if(OK)
            puts("Yes");
        else
            puts("No");
    }
        return 0;
    }

  • 相关阅读:
    五年磨一剑未成
    通过实例学习 VSL Hello World
    Web3d明日之星基于Javascript和OpenGL的技术
    将自己常去Web3D网站整理到文章中来
    FreeBSD,比较安静
    通过实例学习Virtools脚本语言VSL 合并字符串
    关于SQLite
    android中AsyncTask和Handler对比
    JavaScript中Array的prototype运用
    WampServer2.X 安装与使用说明
  • 原文地址:https://www.cnblogs.com/CKboss/p/3351000.html
Copyright © 2011-2022 走看看