zoukankan      html  css  js  c++  java
  • HDOJ 1062 Text Reverse


    Text Reverse

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 12577    Accepted Submission(s): 4743


    Problem Description
    Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
     

    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case contains a single line with several words. There will be at most 1000 characters in a line.
     

    Output
    For each test case, you should output the text which is processed.
     

    Sample Input
    3
    olleh !dlrow
    m'I morf .udh
    I ekil .mca
     

    Sample Output
    hello world!
    I'm from hdu.
    I like acm.
    Hint
    Remember to use getchar() to read ' ' after the interger T, then you may use gets() to read a line and process it.
     

    Author
    Ignatius.L
     




    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <stack>

    using namespace std;
    char str[1000];

    int main()
    {
        int T;
        cin>>T;
        getchar();
    while(T--)
    {
        stack<char> st;
        gets(str);
        int len=strlen(str);
        int i;


        str[len]=' ';
        for(i=0;i<=len;i++)
        {
            if(str!=' ')
            {

               st.push(str);
            }
            else  if(str==' ')
            {

                while(!st.empty())
                {
                    cout<<st.top();
                    st.pop();
                }
                if(i!=len)
                cout<<" ";
                else
                cout<<endl;

            }

        }

    }

        return 0;
    }

     
  • 相关阅读:
    方法
    属性
    Cocoapods完整使用篇
    这样好用的ReactiveCocoa,根本停不下来【转载】
    OS开发之旅之App的生命周期【转载】
    ios 推送证书没有密钥 解决方案【转载】
    移动应用开发测试工具Bugtags集成和使用教程【转载】
    MagicalRecord使用教程【转载】
    GIT客户端的使用【原创】
    iOS开发系列--让你的应用“动”起来【转载】
  • 原文地址:https://www.cnblogs.com/CKboss/p/3351006.html
Copyright © 2011-2022 走看看