zoukankan      html  css  js  c++  java
  • HDOJ 1050 Moving Tables


    Moving Tables

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 14418    Accepted Submission(s): 4939


    Problem Description
    The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 

    HDOJ 1050 Moving Tables - qhn999 - 码代码的猿猿


    The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 

    HDOJ 1050 Moving Tables - qhn999 - 码代码的猿猿


    For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
     

    Input
    The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.
     

    Output
    The output should contain the minimum time in minutes to complete the moving, one per line.
     

    Sample Input
    3
    4
    10 20
    30 40
    50 60
    70 80
    2
    1 3
    2 200
    3
    10 100
    20 80
    30 50
     

    Sample Output
    10
    20
    30
     

    Source
     
    贪心:区间被覆盖的最大遍数

    #include <iostream>
    #include <cstring>
    #include <cstdio>

    using namespace std;

    int w[300];

    int main()
    {
        int T;
        cin>>T;
    while(T--)
    {
        memset(w,0,sizeof(w));
        int n;
        cin>>n;
        int cur=0;
        for(int i=0;i<n;i++)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            if(a>b) swap(a,b);

            if(a&1) a=(a+1)/2;
            else a=a/2;
            if(b&1) b=(b+1)/2;
            else b=b/2;

            for(int j=a;j<=b;j++)
            {
                w[j]++;
                if(w[j]>cur)
                    cur=w[j];
            }
        }


        cout<<cur*10<<endl;

    }
        return 0;
    }

  • 相关阅读:
    学校重理论,公司重操作,计算机专业毕业生该何去何从?
    最简单的ajax示例
    几个简单的例子让你读懂什么是JAVA的堆栈跟踪
    避免在JSP中写java代码
    ==和equals()的区别
    测试,我误解了你
    项目管理十大TION法
    Web测试与APP测试有哪些异同?
    spring cglib 与 jdk 动态代理
    java.util.concurrent.Semaphore 使用
  • 原文地址:https://www.cnblogs.com/CKboss/p/3351007.html
Copyright © 2011-2022 走看看