分组背包
Total Submission(s): 2665 Accepted Submission(s): 1359
ACboy needs your help
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 2665 Accepted Submission(s): 1359
Problem Description
ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[j], (1<=i<=N<=100,1<=j<=M<=100).A[j] indicates if ACboy spend j days on ith course he will get profit of value A[j].
N = 0 and M = 0 ends the input.
Next follow a matrix A
N = 0 and M = 0 ends the input.
Output
For each data set, your program should output a line which contains the number of the max profit ACboy will gain.
Sample Input
2 2
1 2
1 3
2 2
2 1
2 1
2 3
3 2 1
3 2 1
0 0
1 2
1 3
2 2
2 1
2 1
2 3
3 2 1
3 2 1
0 0
Sample Output
3
4
6
4
6
Source
Recommend
lcy
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int a[111][111];
int dp[2][111];
int n,m;
int main()
{
while(scanf("%d%d",&n,&m))
{
if(n==0&&m==0) break;
memset(a,0,sizeof(a));
memset(dp,0,sizeof(dp));
for(int i=1;i<=n;i++)
{
for(int j=1;j<=m;j++)
scanf("%d",&a[j]);
}
for(int k=1;k<=n;k++)
{
for(int i=1;i<=m;i++)
{
for(int j=i;j>=0;j--)
{
dp[k&1]=max(dp[(k-1)&1][i-j]+a[k][j],dp[k&1]);
}
}
}
int ans=-1;
int t=n&1;
for(int i=0;i<=m;i++)
ans=max(ans,dp[t]);
cout<<ans<<endl;
}
return 0;
}