zoukankan      html  css  js  c++  java
  • HDOJ 1712 ACboy needs your help

    分组背包

    ACboy needs your help

    Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 2665    Accepted Submission(s): 1359


    Problem Description
    ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?
     

    Input
    The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
    Next follow a matrix A[j], (1<=i<=N<=100,1<=j<=M<=100).A[j] indicates if ACboy spend j days on ith course he will get profit of value A[j].
    N = 0 and M = 0 ends the input.
     

    Output
    For each data set, your program should output a line which contains the number of the max profit ACboy will gain.
     

    Sample Input
    2 2
    1 2
    1 3
    2 2
    2 1
    2 1
    2 3
    3 2 1
    3 2 1
    0 0
     

    Sample Output
    3
    4
    6
     

    Source
     

    Recommend
    lcy
     

    #include <iostream>
    #include <cstdio>
    #include <cstring>

    using namespace std;

    int a[111][111];
    int dp[2][111];
    int n,m;

    int main()
    {
    while(scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0) break;

        memset(a,0,sizeof(a));
        memset(dp,0,sizeof(dp));

        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
                scanf("%d",&a[j]);
        }

        for(int k=1;k<=n;k++)
        {
            for(int i=1;i<=m;i++)
            {
               for(int j=i;j>=0;j--)
               {
                   dp[k&1]=max(dp[(k-1)&1][i-j]+a[k][j],dp[k&1]);
               }
            }
        }

        int ans=-1;
        int t=n&1;
        for(int i=0;i<=m;i++)
            ans=max(ans,dp[t]);

        cout<<ans<<endl;

    }

        return 0;
    }



  • 相关阅读:
    JAVA练习3
    JAVA练习2
    找出一个整型数组中元素最大值,使用面向对象方法
    类和对象应用例题
    用指针变量作函数形参接收数组地址,解决10个整数按由大到小顺序排序问题
    把指针作为函数参数的方法处理从大到小排序问题。
    通过指针变量访问整型变量
    用选择法对数组中10个整数进行排列
    有参函数的调用
    函数模板
  • 原文地址:https://www.cnblogs.com/CKboss/p/3351018.html
Copyright © 2011-2022 走看看