zoukankan      html  css  js  c++  java
  • POJ 2184 Cow Exhibition

    改变我对背包看法的一题。。。。。


    Cow Exhibition
    Time Limit: 1000MSMemory Limit: 65536K
    Total Submissions: 7484Accepted: 2697

    Description

    "Fat and docile, big and dumb, they look so stupid, they aren't much 
    fun..." 
    - Cows with Guns by Dana Lyons 

    The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow. 

    Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. 

    Input

    * Line 1: A single integer N, the number of cows 

    * Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. 

    Output

    * Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0. 

    Sample Input

    5
    -5 7
    8 -6
    6 -3
    2 1
    -8 -5

    Sample Output

    8

    Hint

    OUTPUT DETAILS: 

    Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF 
    = 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value 
    of TS+TF to 10, but the new value of TF would be negative, so it is not 
    allowed. 

    Source

    USACO 2003 Fall

    锁定变量s,用01背包求对应s的最大f

    #include <iostream>
    #include <cstdio>
    #include <cstring>

    using namespace std;

    int dp[210000];
    const int INF=0x3f3f3f3f;
    const int D=100000;
    int n;
    int s[111];
    int f[111];

    int main()
    {
        cin>>n;
        for(int i=1;i<=n;i++)
            cin>>s>>f;

        for(int i=0;i<210000;i++)
            dp=-INF;
        dp[D]=0;

        for(int i=1;i<=n;i++)
        {
            if(s<0&&f<0)  continue;

            if(s>=0)
            {
                for(int j=100000;j>=-100000;j--)
                    dp[j+D]=max(dp[j+D-s]+f,dp[j+D]);
            }
            else if(s<0)
            {
                for(int j=-100000;j<=100000;j++)
                    dp[j+D]=max(dp[j+D-s]+f,dp[j+D]);
            }
        }

        int ans=0;
        for(int j=0;j<=100000;j++)
        if(dp[j+D]>=0)
            ans=max(ans,dp[j+D]+j);

        cout<<ans<<endl;

        return 0;
    }
     

     
  • 相关阅读:
    交换排序------冒泡法 及其优化
    [编程题]最大和子矩阵
    [编程题] N阶楼梯上楼问题
    2017年东北大学计算机专业考博 面试编程题(某教授 实验室)
    幸运的袋子 (牛客网 16年网易内推 编程题)
    OpenvSwitch代码分析之bridge和port
    阅读书籍---程序员必读系列
    嵌入式开发之davinci--- 8168 电源调试总结
    嵌入式开发之davinci--- 8148/8168/8127 中的添加算饭scd 场景检测 文档简介
    嵌入式开发之davinci--- 8148/8168/8127 中的图像缩放sclr、swms之后出现图像视频卡顿、屏幕跳跃的问题
  • 原文地址:https://www.cnblogs.com/CKboss/p/3351030.html
Copyright © 2011-2022 走看看