zoukankan      html  css  js  c++  java
  • HDOJ 1503 Advanced Fruits


    Advanced Fruits

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 1194    Accepted Submission(s): 584
    Special Judge


    Problem Description
    The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a new fruit emerges that tastes like a mixture between both of them. 
    A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn't sound very interesting. The boss finally decides to use the shortest string that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property. 

    A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example. 

    Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names. 
     

    Input
    Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters.

    Input is terminated by end of file. 
     

    Output
    For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable.
     

    Sample Input
    apple peach
    ananas banana
    pear peach
     

    Sample Output
    appleach
    bananas
    pearch
     

    Source
     

    Recommend
    linle
     



    LCS+递归输出

    #include <iostream>
    #include <cstring>
    #include <cstdio>

    using namespace std;

    char s1[111],s2[111];
    char dp[111][111];
    int v[111][111];

    void output(int a,int b)
    {
        if(a==0&&b==0) return;
        if(dp[a]=='c')
        {
            output(a-1,b-1);
            printf("%c",s1[a-1]);
        }
        else if(dp[a]=='a')
        {
            output(a,b-1);
            printf("%c",s2[b-1]);
        }
        else if(dp[a]=='b')
        {
            output(a-1,b);
            printf("%c",s1[a-1]);
        }
    }

    int main()
    {
    while(scanf("%s%s",s1,s2)!=EOF)
    {
          memset(dp,'-',sizeof(dp));
          memset(v,0,sizeof(v));
          int len1=strlen(s1);
          int len2=strlen(s2);

          for(int i=1;i<=len1+1;i++)
          {
              dp[0]='b';
          }
          for(int i=1;i<=len2+1;i++)
          {
              dp[0]='a';
          }

          for(int i=1;i<=len1;i++)
          {
              for(int j=1;j<=len2;j++)
              {
                  if(s1[i-1]==s2[j-1])
                  {
                      v[j]=v[i-1][j-1]+1;
                      dp[j]='c';
                  }
                  else
                  {
                      if(v[j-1]<v[i-1][j])
                      {
                          v[j]=v[i-1][j];
                          dp[j]='b';
                      }
                      else
                      {
                          v[j]=v[j-1];
                          dp[j]='a';
                      }
                  }
              }
          }
    /*
          for(int i=0;i<=len1+1;i++)
          {
              for(int j=0;j<=len2+1;j++)
                cout<<dp[j]<<" ";
              cout<<endl;
          }

          cout<<":="<<v[len1][len2]<<endl;

    */
          output(len1,len2);
          cout<<endl;
    }
      return  0;
    }
     

  • 相关阅读:
    async await promise写法
    nginx自动启动脚本
    nginx源码编译安装
    PHP源码编译安装
    MySQL修改root密码的多种方法
    PKG_CONFIG_PATH变量 与 ld.so.conf 文件
    confluence5.65+CentOS+mysql安装破解
    nigos core 安装配置
    cacti+CentOS6.5
    Linux+mysql+apache+php
  • 原文地址:https://www.cnblogs.com/CKboss/p/3351033.html
Copyright © 2011-2022 走看看