zoukankan      html  css  js  c++  java
  • HDOJ 1059 Dividing

    惊现多重背包!马上水掉

    Dividing

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 12116    Accepted Submission(s): 3394


    Problem Description
    Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. 
    Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
     

    Input
    Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000. 

    The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.
     

    Output
    For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''. 

    Output a blank line after each test case.
     

    Sample Input
    1 0 1 2 0 0
    1 0 0 0 1 1
    0 0 0 0 0 0
     

    Sample Output
    Collection #1:
    Can't be divided.

    Collection #2:
    Can be divided.
     

    Source
     

    Recommend
    JGShining
     
    #include <iostream>
    #include <cstring>
    #include <cstdio>

    using namespace std;

    int a[7];

    int pack[422222];
    int V;

    void zpack(int*a,int c,int w)
    {
        for(int i=V;i>=c;i--)
            a=max(a,a[i-c]+w);
    }

    void cpack(int*a,int c,int w)
    {
        for(int i=c;i<=V;i++)
            a=max(a,a[i-c]+w);
    }

    void multipack(int* a,int c,int w,int m)
    {
        if(c*m>=V)
        {
            cpack(a,c,w);
            return;
        }
        int k=1;
        while(k<m)
        {
            zpack(a,k*c,k*w);
            m-=k;
            k*=2;
        }

        zpack(a,m*c,m*w);

    }

    int main()
    {
        a[0]=1;
    int cur=0;
    while(a[0])
    {
        int sum=0;
        for(int i=1;i<=6;i++)
        {
            scanf("%d",&a);
            sum+=i*a;
        }

        if(sum==0)  a[0]=0;
        if(a[0]==0) break;

     //   cout<<sum<<endl;
        if(sum&1)  { printf("Collection #%d:\n",++cur); puts("Can't be divided.\n"); continue;}

        memset(pack,0,sizeof(pack));
        V=sum/2;
        for(int i=1;i<=6;i++)
            multipack(pack,i,i,a);
    /*
     for(int i=0;i<=V;i++)
        cout<<pack<<" ";
    cout<<endl;
    */
        if(pack[V]==V)
        {
            printf("Collection #%d:\n",++cur); puts("Can be divided.\n");
        }
        else
        {
            printf("Collection #%d:\n",++cur); puts("Can't be divided.\n");
        }
    }

        return 0;
    }



  • 相关阅读:
    .NET : 单元测试到底给我们带来什么
    .NET : 如何将16进制颜色代码转换为十进制
    LINQ : 谈谈LINQ TO SQL中的直接加载和延迟加载
    .NET : 单元测试的几个Attribute介绍
    .NET : 在单元测试中使用外部文件作为数据源
    再来谈谈json
    .NET : 关于图片格式的问题
    VSTS : 比较性能基准
    .NET : 如何将大文件写入到数据库中
    LINQ : 如何在JOIN或者GROUP BY的时候使用复合键
  • 原文地址:https://www.cnblogs.com/CKboss/p/3351036.html
Copyright © 2011-2022 走看看