zoukankan      html  css  js  c++  java
  • HDOJ 1024 Max Sum Plus Plus

    dp[ i ][ j ]表示从1~~ j  分了 i 段,并且以 a[ j ]结尾的最大长度。

    dp[ i ][ j ] = max( dp[ i ][ j-1] ,  dp[ i-1 ] [ k ]) +a[ j ]     即
    a[ j ] 可以接在最后一段后面,也可以另起一段

    Max Sum Plus Plus

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 12622    Accepted Submission(s): 4159


    Problem Description
    Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

    Given a consecutive number sequence S1, S2, S3, S4 ... Sx, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i, j) = Si + ... + Sj (1 ≤ i ≤ j ≤ n).

    Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + ... + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).

    But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^
     

    Input
    Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 ... Sn.
    Process to the end of file.
     

    Output
    Output the maximal summation described above in one line.
     

    Sample Input
    1 3 1 2 3
    2 6 -1 4 -2 3 -2 3
     

    Sample Output
    6
    8
    Hint
    Huge input, scanf and dynamic programming is recommended.
     

    Author
    JGShining(极光炫影)
     
     

     
    #include <iostream>
    #include <cstdio>
    #include <cstring>

    using namespace std;

    int a[1000100];
    int dp[2][1000100];
    int sum[1000100];
    int f[1000100];
    int n,m;

    int main()
    {
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        sum[0]=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a);
            sum=sum[i-1]+a;
        }

        int ans=-99999999;
        int cur=0;
        for(int j=1;j<=m;j++)
        {
            for(int i=0;i<=j-1;i++)
                dp[1-cur]=-999999999;
            for(int i=j;i<=n;i++)
            {
                if(i==j)  f=sum;
                else f=max(dp[cur][i-1],f[i-1])+a;//如果用3重循环就超时了

                dp[1-cur]=max(dp[1-cur][i-1],f);
                if(j==m)
                    ans=max(ans,f);
            }
            cur=1-cur;
        }
        printf("%d\n",ans);
    }

        return 0;
    }




  • 相关阅读:
    LuoguP2763 试题库问题(最大流)
    LuoguP3254 圆桌问题(最大流)
    LuoguP2765 魔术球问题(最大流)
    LuoguP2764 最小路径覆盖问题(最大流)
    LuoguP4016 负载平衡问题(费用流)
    LuoguP2756 飞行员配对方案问题(最大流)
    BZOJ3675: [Apio2014]序列分割(斜率优化Dp)
    BZOJ1814: Ural 1519 Formula 1(插头Dp)
    BZOJ4652: [Noi2016]循环之美(莫比乌斯反演,杜教筛)
    BZOJ4916: 神犇和蒟蒻(杜教筛)
  • 原文地址:https://www.cnblogs.com/CKboss/p/3351042.html
Copyright © 2011-2022 走看看