zoukankan      html  css  js  c++  java
  • HDOJ 2844 Coins

    特殊的多重背包

    Coins

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 4805    Accepted Submission(s): 1959


    Problem Description
    Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

    You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
     

    Input
    The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
     

    Output
    For each test case output the answer on a single line.
     

    Sample Input
    3 10
    1 2 4 2 1 1
    2 5
    1 4 2 1
    0 0
     

    Sample Output
    8
    4
     

    Source
     

    Recommend
    gaojie
     

    #include <iostream>
    #include <cstring>

    using namespace std;

    int V;
    int dp[100010];
    int c[111],m[111];

    void zpack(int* a,int c,int w)
    {
        for(int i=V;i>=c;i--)
            a=max(a,a[i-c]+w);
    }

    void cpack(int * a,int c,int w)
    {
        for(int i=c;i<=V;i++)
            a=max(a,a[i-c]+w);
    }

    void multipack(int *a,int c,int w,int m)
    {
        if(c*m>=V)
        {
            cpack(a,c,w);
            return ;
        }
        int k=1;
        while(k<m)
        {
            zpack(a,c*k,w*k);
            m-=k;
            k*=2;
        }

        zpack(a,m*c,m*w);
    }

    int main()
    {
    int N;
    while(cin>>N>>V&&(N||V))
    {
        for(int i=0;i<N;i++)
            cin>>c;
        for(int i=0;i<N;i++)
            cin>>m;

        memset(dp,0,sizeof(dp));
        for(int i=0;i<N;i++)
            multipack(dp,c,c,m);

        int ans=0;
        for(int i=1;i<=V;i++)
            if(dp==i) ans++;
        cout<<ans<<endl;
    }

        return 0;
    }

  • 相关阅读:
    两道简单的机试题目
    C#二维数组(矩形数组,交错数组)
    用实例展示left Join,right join,inner join,join,cross join,union 的区别
    React 中的 Redux 详解:
    react 组件通信:
    vue 入门, todoList
    Vue 动画
    vue 框架,入门必看
    koa2 的使用方法:(一)
    git 的使用:
  • 原文地址:https://www.cnblogs.com/CKboss/p/3351050.html
Copyright © 2011-2022 走看看