zoukankan      html  css  js  c++  java
  • POJ 2559 Largest Rectangle in a Histogram

    DP求矩形左右可以扩展的范围
    Largest Rectangle in a Histogram
    Time Limit: 1000MSMemory Limit: 65536K
    Total Submissions: 12112Accepted: 3927

    Description

    A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 
    POJ 2559 Largest Rectangle in a Histogram - qhn999 - 码代码的猿猿

    Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

    Input

    The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integers h1,...,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

    Output

    For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

    Sample Input

    7 2 1 4 5 1 3 34 1000 1000 1000 10000

    Sample Output

    84000

    Hint

    Huge input, scanf is recommended.

    Source

    Ulm Local 2003

     #include <iostream>
    #include <cstring>
    #include <cstdio>

    using namespace std;

    const int MAXN=100000+100;

    long long int a[MAXN];
    long long int l[MAXN];
    long long int r[MAXN];

    int main()
    {
        int n;
        while(scanf("%d",&n)&&n)
        {
            memset(a,0,sizeof(a));

            for(int i=1;i<=n;i++)
                {
                    scanf("%I64d",&a);
                    r=l=i;
                }

            for(int i=1;i<=n;i++)
                while(a[l-1]>=a&&(l-1)>0)
                {
                    l=l[l-1];
                }

            for(int i=n;i>=1;i--)
                while(a[r+1]>=a&&(r+1)<=n)
                {
                    r=r[r+1];
                }
            long long int ans=-999999;
            for(int i=1;i<=n;i++)
                ans=max(ans,a*(r-l+1));

            printf("%I64d\n",ans);

        }
        return 0;
    }



  • 相关阅读:
    POJ 3009
    POJ 3253
    POJ 3617
    POJ 3984
    UVA10012
    HDU5100
    HDU 5101
    UVA301 运输
    UVA 331 交换的方案数
    uva 10344 算23点
  • 原文地址:https://www.cnblogs.com/CKboss/p/3351059.html
Copyright © 2011-2022 走看看