zoukankan      html  css  js  c++  java
  • POJ 2182 Lost Cows

    Lost Cows
    Time Limit: 1000MSMemory Limit: 65536K
    Total Submissions: 8054Accepted: 5130

    Description

    N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood 'watering hole' and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands. 

    Regrettably, FJ does not have a way to sort them. Furthermore, he's not very good at observing problems. Instead of writing down each cow's brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow. 

    Given this data, tell FJ the exact ordering of the cows. 

    Input

    * Line 1: A single integer, N 

    * Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on. 

    Output

    * Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.

    Sample Input

    51210

    Sample Output

    24531

    Source

    #include <cstring>

    using namespace std;

    int n;
    int a[8888];
    int b[8888];
    int c[8888];

    int main()
    {
        int n;

        memset(c,-1,sizeof(c));
        cin>>n;
        for(int i=0;i<n-1;i++)
            cin>>a;

        for(int i=0;i<n;i++)
        {
            c=i+1;
        }
        int cur=n-1;
        for(int i=n-2;i>=0;i--)
        {
            int tot=a;
            for(int j=0;j<n;j++)
            {
                if(tot==0&&c[j]!=-1)
                {
                    b[cur]=c[j];
                    c[j]=-1;
                    cur--;
                    break;
                }
                else if(c[j]!=-1)
                {
                    tot--;
                }
            }
        }
        for(int j=0;j<n;j++)
        {
            if(c[j]!=-1) { b[0]=c[j]; break; }
        }

        for(int i=0;i<n;i++)
            cout<<b<<endl;

        return 0;
    }

  • 相关阅读:
    JSP配置虚拟路径及虚拟主机
    Java中遍历集合的常用方法
    【洛谷P2879】[USACO07JAN]Tallest Cow S
    【洛谷P1080】[NOIP2012 提高组] 国王游戏
    算数基本定理
    【csp202104-3】DHCP服务器
    【csp202104-2】邻域均值
    电话网络
    联通数
    【洛谷P4447】[AHOI2018初中组]分组
  • 原文地址:https://www.cnblogs.com/CKboss/p/3351067.html
Copyright © 2011-2022 走看看