zoukankan      html  css  js  c++  java
  • POJ 2352

    Stars
    Time Limit: 1000MSMemory Limit: 65536K
    Total Submissions: 25554Accepted: 11171

    Description

    Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 
    POJ 2352 - qhn999 - 码代码的猿猿

    For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

    You are to write a program that will count the amounts of the stars of each level on a given map.

    Input

    The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

    Output

    The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

    Sample Input

    51 15 17 13 35 5

    Sample Output

    12110

    Hint

    This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

    Source


    Problem: 2352User: CKboss
    Memory: 636KTime: 407MS
    Language: G++Result: Accepted
    Source Code
     
    #include <cstdio>
    #include <cstring>

    #define N 32005

    using namespace std;

    int tree[N];
    int lis[N];
    int n;

    int Lowbit(int x)
    {
        return x&(-x);
    }

    void Update(int pos,int val)
    {
        while(pos<N)
        {
            tree[pos]+=val;
            pos+=Lowbit(pos);
        }
    }

    int Query(int x)
    {
        int sum=0;
        while(x>0)
        {
            sum+=tree[x];
            x-=Lowbit(x);
        }
        return sum;
    }

    int main()
    {
        int x,y;
        while(scanf("%d",&n)!=EOF)
        {
            memset(lis,0,sizeof(lis));
            memset(tree,0,sizeof(tree));
            for(int i=1;i<=n;i++)
            {
                scanf("%d%d",&x,&y);
                x++;
                lis[Query(x)]++;
                Update(x,1);
            }

            for(int i=0;i<n;i++)
                printf("%d\n",lis);
        }

        return 0;
    }
  • 相关阅读:
    让你爱不释手的图片浮动效果
    Polymer API开发指南 (二)(翻译)
    基于HTML5的拓扑图编辑器(2)
    kbengine开源分布式游戏服务端引擎
    Qunee for HTML5 v1.6新版本发布
    [转载] Link prefetch
    小白学phoneGap《构建跨平台APP:phoneGap移动应用实战》连载三(通过实例来体验生命周期)
    云集,让 web app 像 native app 那样运行(雄起吧,Web 开发者)
    Android设置ToolBar的title文字居中显示
    Task 'assembleXXXDebug' not found in project ':app'.的解决方法
  • 原文地址:https://www.cnblogs.com/CKboss/p/3351075.html
Copyright © 2011-2022 走看看