zoukankan      html  css  js  c++  java
  • POJ 2287 Tian Ji The Horse Racing

    Tian Ji -- The Horse Racing

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) :   Accepted Submission(s) :
    Problem Description
    Here is a famous story in Chinese history.

    "That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

    "Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

    "Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

    "Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

    "It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"

    POJ 2287 Tian Ji -- The Horse Racing - qhn999 - 码代码的猿猿

    Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

    However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

    In this problem, you are asked to write a program to solve this special case of matching problem.
     

    Input
    The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.
     

    Output
    For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.
     

    Sample Input
    3
    92 83 71
    95 87 74
    2
    20 20
    20 20
    2
    20 19
    22 18
    0
     

    Sample Output
    200
    0
    0
     

    Source
    2004 Asia Regional Shanghai
     



    #include <iostream>
    #include <algorithm>

    using namespace std;

    int tj[1010];
    int qw[1010];

    bool cmp(int a,int b)
    {
        if(a>b)  return true;
        else return false;
    }

    int main()
    {
        int n;
        while(cin>>n&&n)
        {
            int sum=0;
            for(int i=0;i<n;i++)
                cin>>tj;
            for(int i=0;i<n;i++)
                cin>>qw;

            sort(tj,tj+n,cmp);
            sort(qw,qw+n,cmp);

            int ts=0,te=n-1; int qs=0,qe=n-1;

            while(ts<=te)
            {
                if(tj[ts]>qw[qs])
                {
                    sum+=200;
                    ts++;
                    qs++;
                }
                else if(tj[te]>qw[qe])
                {
                    sum+=200;
                    qe--;
                    te--;
                }
                else
                {
                    if(tj[te]<qw[qs])
                      sum-=200;
                      te--;
                      qs++;
                }

            }

            cout<<sum<<endl;

        }

        return 0;
    }


  • 相关阅读:
    Ubuntu14.04+cuda 7.5+cudnn_v4+tensorflow安装
    error C2275: “XXX”: 将此类型用作表达式非法
    DLL调试方法
    OpenCV ——双线性插值(Bilinear interpolation)
    OpenCV ——背景建模之CodeBook(2)
    OpenCV ——背景建模之CodeBook(1)
    OpenCV——GMM混合高斯模型
    OpenCV——运用于pixels war游戏
    【SpringSecurityOAuth2】源码分析@EnableOAuth2Sso在Spring Security OAuth2 SSO单点登录场景下的作用
    【Spring】简述@Configuration配置类注册BeanDefinition到Spring容器的过程
  • 原文地址:https://www.cnblogs.com/CKboss/p/3351084.html
Copyright © 2011-2022 走看看