zoukankan      html  css  js  c++  java
  • 【POJ2096】Collecting Bugs 期望

    【POJ2096】Collecting Bugs

    Description

    Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program. 
    Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category. 
    Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It's important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan's opinion about the reliability of the obsolete version. 
    A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem. 
    Find an average time (in days of Ivan's work) required to name the program disgusting.

    Input

    Input file contains two integer numbers, n and s (0 < n, s <= 1 000).

    Output

    Output the expectation of the Ivan's working days needed to call the program disgusting, accurate to 4 digits after the decimal point.

    Sample Input

    1 2

    Sample Output

    3.0000

    题意:有n种BUG,s个系统,每天发现1个系统的1个BUG,假定每种BUG的个数无限多(每次发现一种BUG的概率都是1/n),问发现每种BUG且每个系统里都发现了BUG的期望天数。

    题解:设f[i][j]为已经在 j 个系统里发现了 i 种BUG还需要的天数,方程很显然

    f[i][j]=f[i+1][j+1]*P1+f[i+1][j]*P2+f[i][j+1]*P3+f[i][j]*P4 (P1,P2,P3,P4是什么我就不用再说了)

    发现等号两边都有f[i][j],移项即可

    #include <cstdio>
    #include <cmath>
    #include <iostream>
    using namespace std;
    int n,s;
    double f[1010][1010];
    int main()
    {
        scanf("%d%d",&n,&s);
        for(int i=n;i>=0;i--)
            for(int j=s;j>=0;j--)
                if(i!=n||j!=s)
                    f[i][j]=(f[i+1][j+1]*(n-i)*(s-j)+f[i+1][j]*(n-i)*j+f[i][j+1]*i*(s-j)+1.0*s*n)/(1.0*s*n-i*j);
        printf("%.4f",f[0][0]);
        return 0;
    }
  • 相关阅读:
    Django 06模板语言的复用
    Django 07模型层—单表操作
    Django 05模板-变量、过滤器、 标签
    Django 04(视图层基础01)
    Django 03 (路由层基础)
    Django--02(项目创建,数据请求迁移,单表orm增删改查)
    Web 文本、reset操作、高级选择器、边界圆角、a的四大伪类、精灵图
    web前端 基础选择器、长度与颜色、display、嵌套、盒模型
    MySQL之数据库的常用语句
    PHP中级篇 Apache配置httpd-vhosts虚拟主机总结及注意事项(转载)
  • 原文地址:https://www.cnblogs.com/CQzhangyu/p/6192476.html
Copyright © 2011-2022 走看看