zoukankan      html  css  js  c++  java
  • 【搜索】POJ-3050 基础DFS

    一、题目

    Description

    The cows play the child's game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes. 
    They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited). 
    With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201). 
    Determine the count of the number of distinct integers that can be created in this manner.

    Input

    * Lines 1..5: The grid, five integers per line

    Output

    * Line 1: The number of distinct integers that can be constructed

    Sample Input

    1 1 1 1 1
    1 1 1 1 1
    1 1 1 1 1
    1 1 1 2 1
    1 1 1 1 1
    

    Sample Output

    15
    

    Hint

    OUTPUT DETAILS: 
    111111, 111112, 111121, 111211, 111212, 112111, 112121, 121111, 121112, 121211, 121212, 211111, 211121, 212111, and 212121 can be constructed. No other values are possible.

    二、思路&心得

    • 利用set集合保证数据不重复,最后直接输出set的大小即可
    • 基础深搜,数据量较弱

    三、代码

    #include<cstdio>
    #include<set>
    #define MAX_SIZE 5
    using namespace std;
    
    set<int> s;
    
    int N, M;
    
    int a[10];
    
    int map[MAX_SIZE][MAX_SIZE];
    
    int dirction[4][2] = {0, -1, -1, 0, 0, 1, 1, 0};
    
    bool isLegal(int x, int y) {
    	if (x >= 0 && x < MAX_SIZE && y >= 0 && y < MAX_SIZE) return true;
    	else return false;
    }
    
    void dfs(int x, int y, int k) {
    	if (k == 6) {
    		int num = a[0];
    		for (int j = 1; j < 6; j ++) {
    			num = num * 10 + a[j];
    		}
    		s.insert(num);
    		return;
    	}
    	for(int i = 0; i < 4; i ++) {
    		int tx = x + dirction[i][0], ty = y + dirction[i][1];
    		if (isLegal(tx, ty)) {
    			a[k] = map[tx][ty];
    			dfs(tx, ty, k + 1);
    		}
    	}
    } 
    
    int main() {
    	for (int i = 0; i < 5; i ++) {
    		for (int j = 0; j < 5; j ++) {
    			scanf("%d", &map[i][j]);
    		}
    	}
    	for (int i = 0; i < 5; i ++) {
    		for (int j = 0; j < 5; j ++) {
    			a[0] = map[i][j];
    			dfs(i, j, 1);
    		}
    	}
    	printf("%d", s.size());
    	return 0;
    }
    
  • 相关阅读:
    .a包生成64位
    iOS教程
    iOS 难题解决日志------2层控制器 上面的控制器显示透明
    企业级的App发布流程
    如何从oc中去获取一个私有的变量.....
    iOS app的破解原理,就是去除已付费的账户信息的原理是什么?
    Could not launch "app_name"
    GCD时间轴
    Win8自动更新怎么关闭 取消Win8自动更新
    python3 elf文件解析
  • 原文地址:https://www.cnblogs.com/CSLaker/p/7281237.html
Copyright © 2011-2022 走看看