zoukankan      html  css  js  c++  java
  • HDOJ1162。。。

    Eddy's picture

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 3412    Accepted Submission(s): 1672


    Problem Description
    Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
    Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?
     
    Input
    The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.

    Input contains multiple test cases. Process to the end of file.
     
    Output
    Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.
     
    Sample Input
    3 1.0 1.0 2.0 2.0 2.0 4.0
     
    Sample Output
    3.41

    //优化未遂。。。

    #include <stdio.h>
    #include <math.h>
    #include <string.h>
    #define N 105
    typedef struct
    {
    double x,y;
    }Point;

    int n;//题目涉及n个点
    Point p[N];//n个点的坐标
    double M[N][N];//n*n的矩阵,元素为距离,【按上三角矩阵存储】
    double len,min_dis;//总距离
    int queue[N];//队列
    int idx_q;//队列的游标
    int v[N];//访问标志

    double dist(int i,int j)//计算p[i]和p[j]的距离
    {
    double x,y;
    x = p[i].x-p[j].x;
    y = p[i].y-p[j].y;
    return sqrt(x*x+y*y);
    }
    int main()
    {
    int i,j,ty,k;
    while (scanf("%d",&n)!=EOF)
    {
    //构造矩阵
    for (i=0;i<n;i++)
    {
    scanf("%lf%lf",&p[i].x,&p[i].y);
    for (j=0; j<i; j++)
    M[i][j]= M[j][i] = dist(i,j);
    }
    //构造最小生成树
    memset(v,0,sizeof(v));
    len = 0.0;
    idx_q=0;
    v[0]=1;
    queue[idx_q++]=0;
    while (idx_q<n)//填满为止
    {
    //根据队列前idx_q个元素找下一个点
    min_dis = 0xfffffff;
    for (k=0;k<idx_q;k++)
    {
    i=queue[k];
    for (j=0;j<n;j++)
    {
    if (j!=i && min_dis>M[i][j] && v[j]==0)
    {
    min_dis = M[i][j];
    ty = j;
    }
    }
    }
    len += min_dis;
    v[ty]=1;
    queue[idx_q++]=ty;
    }
    printf("%.2lf\n",len);
    }
    return 0;
    }

    4月1日:今天看了数据结构的教材,原来我的算法类似于Prim算法,但是我的算法中没有用到辅助数组,这就把复杂度增加了。。。

    字节跳动内推

    找我内推: 字节跳动各种岗位
    作者: ZH奶酪(张贺)
    邮箱: cheesezh@qq.com
    出处: http://www.cnblogs.com/CheeseZH/
    * 本文版权归作者和博客园共有,欢迎转载,但未经作者同意必须保留此段声明,且在文章页面明显位置给出原文连接,否则保留追究法律责任的权利。

  • 相关阅读:
    LeetCode_167. Two Sum II
    LeetCode_160. Intersection of Two Linked Lists
    LeetCode_155. Min Stack
    LeetCode_141. Linked List Cycle
    LeetCode_136. Single Number
    LeetCode_125. Valid Palindrome
    HTML解析类 ,让你不使用正则也能轻松获取HTML相关元素 -C# .NET
    .net 根据匿名类生成实体类,根据datatable生成实体类,根据sql生成实体类
    将form表单元素转为实体对象 或集合 -ASP.NET C#
    ASP.NET 图片上传工具类 upload image简单好用功能齐全
  • 原文地址:https://www.cnblogs.com/CheeseZH/p/2427692.html
Copyright © 2011-2022 走看看