zoukankan      html  css  js  c++  java
  • [BZOJ] 1646: [Usaco2007 Open]Catch That Cow 抓住那只牛

    1646: [Usaco2007 Open]Catch That Cow 抓住那只牛

    Time Limit: 5 Sec  Memory Limit: 64 MB
    Submit: 1266  Solved: 599
    [Submit][Status][Discuss]

    Description

    Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 <= N <= 100,000) on a number line and the cow is at a point K (0 <= K <= 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X-1 or X+1 in a single minute * Teleporting: FJ can move from any point X to the point 2*X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

        农夫约翰被通知,他的一只奶牛逃逸了!所以他决定,马上幽发,尽快把那只奶牛抓回来.
        他们都站在数轴上.约翰在N(O≤N≤100000)处,奶牛在K(O≤K≤100000)处.约翰有
    两种办法移动,步行和瞬移:步行每秒种可以让约翰从z处走到x+l或x-l处;而瞬移则可让他在1秒内从x处消失,在2x处出现.然而那只逃逸的奶牛,悲剧地没有发现自己的处境多么糟糕,正站在那儿一动不动.
        那么,约翰需要多少时间抓住那只牛呢?

    Input

    * Line 1: Two space-separated integers: N and K

        仅有两个整数N和K.

    Output

    * Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

        最短的时间.

    Sample Input

    5 17
    Farmer John starts at point 5 and the fugitive cow is at point 17.

    Sample Output

    4

    OUTPUT DETAILS:

    The fastest way for Farmer John to reach the fugitive cow is to
    move along the following path: 5-10-9-18-17, which takes 4 minutes.

    HINT

     

    Source

    Silver

    Analysis

    BFS!

    Code

    #include<cstdio>
    #include<iostream>
    #include<queue>
    #define maxn 1010101
    using namespace std;
    
    bool judge(int x){
        return x < maxn && x >= 0;
    }
    
    struct node{
        int pos,step;
    };
    
    bool book[maxn];
    int n,k;
    
    void bfs(){
        queue<node> Q;
        Q.push((node){n,0});
        book[n] = true;
        
        while(!Q.empty()){
            node now = Q.front();
            Q.pop();
            
            if(now.pos == k){
                printf("%d",now.step);
                return;
            }
            
            if(judge(now.pos+1) && !book[now.pos+1]){
                book[now.pos+1] = true;
                Q.push((node){now.pos+1,now.step+1});
            }
            
            if(judge(now.pos-1) && !book[now.pos-1]){
                book[now.pos-1] = true;
                Q.push((node){now.pos-1,now.step+1});
            }
            
            if(judge(now.pos*2) && !book[now.pos*2]){
                book[now.pos*2] = true;
                Q.push((node){now.pos*2,now.step+1});
            }
        }
    }
    
    int main(){
        scanf("%d%d",&n,&k);
        
        book[n] = true;
        bfs();
        
        return 0;
    }
    心情不好qwq
    转载请注明出处 -- 如有意见欢迎评论
  • 相关阅读:
    Centos7安装Docker
    [LeetCode] 651. 四键键盘 ☆☆☆(动态规划)
    一行代码就能解决的算法题
    博弈问题--石头游戏(动态规划)
    [LeetCode] 322. 零钱兑换 ☆☆☆(动态规划)
    java趣题
    [LeetCode] 516. 最长回文子序列 ☆☆☆(动态规划)
    [LeetCode] 337. 打家劫舍III ☆☆☆(动态规划)
    算法基础--贪心算法
    [LeetCode] 42. 接雨水 ☆☆☆☆☆(按列、动态规划、双指针)
  • 原文地址:https://www.cnblogs.com/Chorolop/p/7474766.html
Copyright © 2011-2022 走看看