Least Common Multiple
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 20759 Accepted Submission(s): 7738
Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
Sample Input
2
3 5 7 15
6 4 10296 936 1287 792 1
Sample Output
105
10296
- #include<iostream>
- #include<cstdio>
- using namespace std;
- int a[10000];
- int gcd(int a,int b)
- {
- if(b==0)
- return a;
- return gcd(b,a%b);
- }
- int lcm(int a,int b)
- {
- return a/gcd(a,b)*b; }
- int main()
- {
- int i,j,t;
- scanf("%d",&t);
- while(t--)
- {
- int temp,n;
- scanf("%d",&n);
- for(i=0;i<n;i++)
- {
- scanf("%d",&a[i]);
- }
- temp=a[0];
- for(i=1;i<n;i++)
- {
- temp=lcm(temp,a[i]);
- }
- printf("%d\n",temp);
- }
- return 0;
- }