zoukankan      html  css  js  c++  java
  • uva10034

    Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

    []   [Go Back]   [Status]  

    Description

    Problem A: Freckles

    In an episode of the Dick Van Dyke show, little Richie connects the freckles on his Dad's back to form a picture of the Liberty Bell. Alas, one of the freckles turns out to be a scar, so his Ripley's engagement falls through.

    Consider Dick's back to be a plane with freckles at various (x,y) locations. Your job is to tell Richie how to connect the dots so as to minimize the amount of ink used. Richie connects the dots by drawing straight lines between pairs, possibly lifting the pen between lines. When Richie is done there must be a sequence of connected lines from any freckle to any other freckle.

    Input

    The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.

     

    The first line contains 0 < n <= 100, the number of freckles on Dick's back. For each freckle, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the freckle.

    Output

    For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.

     

    Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the freckles.

    Sample Input

    1
    
    3
    1.0 1.0
    2.0 2.0
    2.0 4.0
    

    Sample Output

    3.41


    #include<iostream>
    #include<string>
    #include<stdio.h>
    #include<algorithm>
    #include<cmath>
    using namespace std;
    struct point
    {  double x,y; };
    struct edge
    {  int u,v;  double w; };
    int i,j;
    edge e[1000001];
    point p[101];
    int f[101]; int n; int u[101],v[101]; int l;
    bool cmp(const edge&x,const edge&y)
    {
     return x.w<y.w;
    }
    int find2(int x)
    {
     return x==f[x]?x:f[x]=find2(f[x]);
    }
    double solve()
    {  
    for( i=0;i<n;i++)
    f[i]=i;
     double s=0;
     for( i=0;i<l;i++)
     {  
    int a=find2(e[i].u),b=find2(e[i].v);
      if(a!=b)  
    {   
    f[a]=b;    s=s+e[i].w;  
    }
     }
     return s;
    }
    int main()
    {  
    int t;   int ca=0;   cin>>t;
     while(t--)  
    {  
    if(ca!=0)cout<<endl;   ca++;  
    cin>>n;   int len=0;  
    for( i=0;i<n;i++)  
    {  
      cin>>p[i].x>>p[i].y;
      }
      l=0;  
    for( i=0;i<n;i++)   
    for( j=i+1;j<n;j++)    
      {     
    e[l].u=i;    
    e[l].v=j;  
       e[l].w=sqrt((p[i].x-p[j].x)*(p[i].x-p[j].x)+(p[i].y-p[j].y)*(p[i].y-p[j].y));  
       l++;   
       }
       sort(e,e+l,cmp);   
    printf("%.2lf\n",solve());
     } 
     return 0;
    }
  • 相关阅读:
    4 Python+Selenium的元素定位方法(link/partial link)
    3 Python+Selenium的元素定位方法(id、class name、name、tag name)
    2 Selenium3.0+Python3.6环境搭建
    1 Selenium打开浏览器
    目录处理文件&链接命令
    DOS批处理命令-@命令
    DOS批处理命令-echo
    吐槽一二三
    编码神器之sublime(插件安装)
    两天来学习C的感受
  • 原文地址:https://www.cnblogs.com/Deng1185246160/p/2981559.html
Copyright © 2011-2022 走看看