zoukankan      html  css  js  c++  java
  • poj2828

                                                                                              Buy Tickets
    Time Limit: 4000MS   Memory Limit: 65536K
    Total Submissions: 10677   Accepted: 5173

    Description

    Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

    The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

    It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

    People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

    Input

    There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Valiin the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

    • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
    • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

    There no blank lines between test cases. Proceed to the end of input.

    Output

    For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

    Sample Input

    4
    0 77
    1 51
    1 33
    2 69
    4
    0 20523
    1 19243
    1 3890
    0 31492

    Sample Output

    77 33 69 51
    31492 20523 3890 19243

    Hint

    The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

     

     

    #include<iostream>
    #include<cstring>
    #include<string>
    using namespace std;
    const int maxn = 200010;
    int c[maxn],n;
    struct Node
    {
        int A,B;
    }tree[maxn*2];
    int lowbit(int x)
    {
        return x & -x;
    }
    int sum(int x)
    {
        int sum1 = 0;
        while(x>0)
        {
            sum1 += c[x];
            x -= lowbit(x);
        }
        return sum1;
    }
    void add(int x)
    {
        while(x<n)
        {
            c[x]++;
            x += lowbit(x);
        }
    }
    int main()
    {
        int ans[maxn],i;
        while(scanf("%d",&n)!=EOF)
        {
            int as = 0;
            memset(c,0,sizeof(c));
            for(i=1;i<=n;i++)
            {
                scanf("%d %d",&tree[i].A,&tree[i].B);
                tree[i].A++;
            }
    /* 这下面很巧妙的插入*/
    for(i=n;i>=1;i--) { int l = 1; int r = n; while(l<=r) { int m = (l+r)/2; if(m-sum(m)>=tree[i].A) { r = m- 1; as = m; } else l = m +1; } ans[as] = tree[i].B; add(as); } for(i=1;i<=n-1;i++) { printf("%d ",ans[i]); } printf("%d ",ans[n]); } return 0; }
  • 相关阅读:
    linux学习笔记-11.正则表达式
    linux学习笔记-10.解压与压缩
    linux学习笔记-9.查找
    linux学习笔记-8.vim
    linux学习笔记-7.文件属性
    linux学习笔记-6.权限
    linux学习笔记-5.用户和组
    @Param注解的用法解析
    linux学习笔记-4.系统命令
    linux学习笔记-3.文件相关命令
  • 原文地址:https://www.cnblogs.com/Deng1185246160/p/3256670.html
Copyright © 2011-2022 走看看