zoukankan      html  css  js  c++  java
  • The Little Girl who Picks Mushrooms HDU 4422 水题类似模拟的一种感觉

    The Little Girl who Picks Mushrooms

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 1070    Accepted Submission(s): 346


    Problem Description
    It's yet another festival season in Gensokyo. Little girl Alice planned to pick mushrooms in five mountains. She brought five bags with her and used different bags to collect mushrooms from different mountains. Each bag has a capacity of 2012 grams. Alice has finished picking mushrooms in 0 ≤ n ≤ 5 mountains. In the i-th mountain, she picked 0 ≤ wi ≤ 2012 grams of mushrooms. Now she is moving forward to the remained mountains. After finishing picking mushrooms in all the five mountains, she want to bring as much mushrooms as possible home to cook a delicious soup.
    Alice lives in the forest of magic. At the entry of the forest of magic, live three mischievous fairies, Sunny, Lunar and Star. On Alice's way back home, to enter the forest, she must give them exactly three bags of mushrooms whose total weight must be of integral kilograms. If she cannot do so, she must leave all the five bags and enter the forest with no mushrooms.
    Somewhere in the forest of magic near Alice's house, lives a magician, Marisa. Marisa will steal 1 kilogram of mushrooms repeatedly from Alice until she has no more than 1 kilogram mushrooms in total. So when Alice gets home, what's the maximum possible amount of mushrooms Alice has? Remember that our common sense doesn't always hold in Gensokyo. People in Gensokyo believe that 1 kilogram is equal to 1024 grams.
     
    Input
    There are about 8192 test cases. Proceed to the end of file.
    The first line of each test case contains an integer 0 ≤ n ≤ 5, the number of mountains where Alice has picked mushrooms. The second line contains n integers 0 ≤ wi≤ 2012, the amount of mushrooms picked in each mountain.
     
    Output
    For each test case, output the maximum possible amount of mushrooms Alice can bring home, modulo 20121014 (this is NOT a prime).
     
    Sample Input
    1 9 4 512 512 512 512 5 100 200 300 400 500 5 208 308 508 708 1108
     
    Sample Output
    1024 1024 0 792
    Hint
    In the second sample, if Alice doesn't pick any mushrooms from the 5-th mountain. She can give (512+512+0) =1024 grams of mushrooms to Sunny, Lunar and Star. Marisa won't steal any mushrooms from her as she has exactly 1 kilogram of mushrooms in total. In the third sample, there are no three bags whose total weight is of integral kilograms. So Alice must leave all the five bags and enter the forest with no mushrooms. In the last sample: 1.Giving Sunny, Lunar and Star: (208+308+508)=1024 2.Stolen by Marisa: ((708+1108)-1024)=792
     
    Source
     
    Recommend
    zhuyuanchen520   |   We have carefully selected several similar problems for you:  4769 4768 4767 4766 4765 
     
    #include<iostream>
    #include<cstdio>
    using namespace std;
    #define rep(i,a,b) for(int i=a; i<=b; i++)
    typedef long long lint;
    
    int num[10];
    int main()
    {
       //freopen("2.txt","r",stdin);
       int n;
       while(scanf("%d",&n) == 1)
       {
           //int ans;
           int sum = 0;
           rep(i,1,n)
           {
             scanf("%d",&num[i]);
             sum += num[i];
           }
    
           if(n<=3)
           {
            cout<<1024<<endl;
            continue;
           }
           int ans = 0;
           if(n==4)
           {
    
              rep(i,1,n)
              {
                  int tmp = sum - num[i];
                  if(tmp%1024 == 0)
                  {
                     ans = 1024;
                     goto here;
                  }
              }
    
              rep(i,1,n)
               rep(j,i+1,n)
               {
                  int temp = num[i] + num[j];
    
                  if(temp%1024 == 0 && temp)
                  {
                   ans = 1024;
                    goto here;
                  }
                  ans = max(ans,temp%1024);
               }
           }
    
           if(n==5)
           {
              rep(i,1,n)
                rep(j,i+1,n)
                {
                   int temp = num[i] + num[j];
                   if((sum - temp)%1024 == 0)
                   {
                       if(temp%1024 == 0 &&temp)
                       {
                         ans = 1024;
                         goto here;
                       }
                      ans  = max(ans,temp%1024);
                   }
                }
           }
    here:
           cout<<ans<<endl;
       }
    
       return 0;
    }
  • 相关阅读:
    面对苹果的抄袭指责,小米到底有没有抄袭?
    如何用Ajax传一个数组数据
    为何日本人如此重视孩子的早餐问题
    常见编程语言对REPL支持情况小结
    坚持未必都是美德,也可能是无知
    PHP 5.4语法改进与弃用特性
    解决CI框架的Disallowed Key Characters错误提示
    如何抓取开了gzip的网页
    CodeIgniter自带的数据库类使用介绍
    Python内部变量与外部变量
  • 原文地址:https://www.cnblogs.com/DreamHighWithMe/p/3382906.html
Copyright © 2011-2022 走看看