zoukankan      html  css  js  c++  java
  • PAT 甲级 1011 World Cup Betting (20)(代码+思路)

    1011 World Cup Betting (20)(20 分)

    With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

    Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

    For example, 3 games' odds are given as the following:

     W    T    L
    1.1  2.5  1.7
    1.2  3.0  1.6
    4.1  1.2  1.1
    

    To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).

    Input

    Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

    Output

    For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

    Sample Input

    1.1 2.5 1.7
    1.2 3.0 1.6
    4.1 1.2 1.1
    

    Sample Output

    T T W 37.98

    思路:找出每一种游戏赔率的最大值,按照题目要求进行计算。

    #include<iostream>
    #include<string>
    using namespace std;
    int main() {
    	string res[3], m[3] = { "W","T","L" };   //res存放结果,m用于赋值
    	double t, max, sum = 1;  //sum初始化为1
    	for (int i = 0; i < 3; i++) {
    		max = 0;   //每一个游戏的赔率一定比0 大
    		for (int j = 0; j < 3; j++) {
    			cin >> t;
    			if (t > max) {
    				max = t;   //更新max
    				res[i] = m[j];   //更新res
    			}
    		}
    		sum *= max;
    	}
    	sum = (sum*0.65 - 1) * 2;
    	cout << res[0] << " " << res[1] << " " << res[2];
    	printf(" %.2lf", sum);
    	return 0;
    }
  • 相关阅读:
    ocky勒索软件恶意样本分析1
    勒索软件Locky、Tesalcrypt等使用了新的工具躲避检测
    ocky勒索软件恶意样本分析2
    “小马激活”病毒新变种分析报告
    你的应用是如何被替换的,App劫持病毒剖析
    巧妙防治网上病毒侵害的方法步骤
    “僵尸之手”:一种伪装成正常应用的恶意病毒(病毒防范方法解说)
    利用C&C漏洞来查看恶意软件Dridex的操作流程
    CITRIX ADC配置SSL卸载
    防火墙TCP的单向控制
  • 原文地址:https://www.cnblogs.com/F-itachi/p/9974369.html
Copyright © 2011-2022 走看看