zoukankan      html  css  js  c++  java
  • HDU4004 The Frog's Games

    HDU4004 The Frog's Games

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)

    Total Submission(s): 941    Accepted Submission(s): 508

    Problem Description

    The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they 

    are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog's longest jump distance).

    Input

    The input contains several cases. The first line of each case contains three positive integer L, n, and m. 

    Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.

    Output

    For each case, output a integer standing for the frog's ability at least they should have.

    Sample Input

    6 1 2

    2

    25 3 3

    11 

    2

    18

    Sample Output

    4

    11

    ******************************************************************

    这是2011年大连赛区网络赛的第四题,简单二分答案+贪心,不解释。

    #include <stdio.h>
    #include <algorithm>
    
    int pos[500005];
    int len,n,tim;
    int max(int a,int b){return a>b?a:b;}
    
    int ifok(int k)
    {
        int now=0;
        for(int i=1;i<=tim;i++)
        {
            int j;
            for(j=now;pos[j+1]-pos[now]<=k;j++);
            now=j;
            if(now==n+1)return 1;
        }
        return 0;
    }
    
    int main()
    {
        while(scanf("%d%d%d",&len,&n,&tim)==3)
        {
            int maxx=-1;
            pos[0]=0;
            for(int i=1;i<=n;i++)
                scanf("%d",&pos[i]);
            std::sort(pos+1,pos+1+n);
            for(int i=1;i<=n;i++)
                maxx=max(maxx,pos[i]-pos[i-1]);
            pos[n+1]=len;
            pos[n+2]=0x3f3f3f3f;
            maxx=max(maxx,pos[n+1]-pos[n]);
            int le=maxx-1,ri=len,mid;
            while(mid=(ri+le)/2,ri>le)
            {
                if(ifok(mid))
                    ri=mid;
                else
                    le=mid+1;
            }
            printf("%d\n",ri);
        }
    }
    

      

  • 相关阅读:
    ZLL网关程序分析
    ZLL主机接口的信息处理流程
    TI Zigbee Light Link 参考设计
    基于能量收集的智能家居-2013国家级大学生创业实践项目申报_商业计划书_V0.2
    office excel 装Visual Studio后报错解决方案
    php随机生成验证码
    Mysql添加外键约束
    hdu 1232 畅通工程
    hdu 1162 Eddy's picture (Kruskal 算法)
    hdu 1102 Constructing Roads (Prim算法)
  • 原文地址:https://www.cnblogs.com/Fatedayt/p/2177903.html
Copyright © 2011-2022 走看看