zoukankan      html  css  js  c++  java
  • POJ2115 C Looooops

    POJ2115 C Looooops
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 11146   Accepted: 2622

    Description

    A Compiler Mystery: We are given a C-language style for loop of type 
    for (variable = A; variable != B; variable += C)
    
    statement;

    I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2k) modulo 2k

    Input

    The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2k) are the parameters of the loop. 

    The input is finished by a line containing four zeros. 

    Output

    The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate. 

    Sample Input

    3 3 2 16
    3 7 2 16
    7 3 2 16
    3 4 2 16
    0 0 0 0
    

    Sample Output

    0
    2
    32766
    FOREVER
    *****************************************************************************
    题目大意:不说什么了。
    解题思路:扩展欧几里德。
    唉。刚刚上手,表示各种艰难呐!!!!!!!
    #include <stdio.h>
    #define LL long long
    
    LL exgcd(LL a,LL b,LL &x,LL &y)
    {
        if(!b)return x=1,y=0,a;
        LL d=exgcd(b,a%b,x,y);
        LL c=x;
        return x=y,y=c-a/b*y,d;
    }
    
    int main()
    {
        LL a,b,c,k,x,y;
        while(scanf("%I64d%I64d%I64d%I64d",&a,&b,&c,&k),a+b+c+k)
        {
            k=((LL)1<<k);
            LL d=exgcd(c,k,x,y);
            if((b-a)%d)
                printf("FOREVER\n");
            else
            {
                x=(b-a)/d*x;
                LL s=k/d;
                x=(x%s+s)%s;
                printf("%I64d\n",x);
            }
        }
    }
    

      


    也许有挫折,但这些,怎能挡住湘北前进的步伐
  • 相关阅读:
    MarkDown测试
    在Tabbed Activity(ViewPager)中切换Fragment
    About ListView
    Android Studio的技巧
    卷积神经网络
    TensorFlow中CNN的两种padding方式“SAME”和“VALID”
    tensorflow-解决3个问题
    激活函数
    tensorflow数学运算
    tensorflow
  • 原文地址:https://www.cnblogs.com/Fatedayt/p/2229487.html
Copyright © 2011-2022 走看看