zoukankan      html  css  js  c++  java
  • HDU1711 Number Sequence

    HDU1711 Number Sequence

    Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 3852    Accepted Submission(s): 1781


    Problem Description
    Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
     
    Input
    The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
     
    Output
    For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
     
    Sample Input

    2
    13 5
    1 2 1 2 3 1 2 3 1 3 2 1 2
    1 2 3 1 3
    13 5
    1 2 1 2 3 1 2 3 1 3 2 1 2
    1 2 3 2 1

     

    Sample Output

    6
    -1
    *******************************************************
    题目大意:其实不必解释。
    解题思路:最裸的KMP。
    #include <stdio.h>
    #include <string.h>
    #define N 1000005
    #define M 10005
    
    int a[N],b[M];
    int n,m;
    int p[M];
    
    void re(void)
    {
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        for(int i=0;i<m;i++)
            scanf("%d",&b[i]);
    }
    
    void run(void)
    {
        memset(p,-1,sizeof(p));
        for(int i=1;i<m;i++)
        {
            int k=p[i-1];
            while(1)
            {
                if(b[i]==b[k+1])
                {
                    p[i]=k+1;
                    break;
                }
                if(k==-1)break;
                k=p[k];
            }
        }
        int j=-1;
        for(int i=0;i<n;i++)
        {
            while(1)
            {
                if(a[i]==b[j+1])
                {
                    j++;
                    if(j+1==m)
                    {
                        printf("%d\n",i-j+1);
                        return ;
                    }
                    break;
                }
                if(j==-1)break;
                j=p[j];
            }
        }
        puts("-1");
    }
    
    int main()
    {
        freopen("/home/fatedayt/in","r",stdin);
        int ncase;
        scanf("%d",&ncase);
        while(ncase--)
        {
            re();
            run();
        }
        return 0;
    }
    
  • 相关阅读:
    当前毫秒时间戳
    生成随机指定长度的字符串
    symfony框架学习
    Git 学习一
    jmeter逻辑控制器
    jmeter执行顺序及作用域规则
    jmeter常用测试元件
    windows环境下jmeter生成测试报告
    jmeter参数化
    对网页进行截图(selenium)
  • 原文地址:https://www.cnblogs.com/Fatedayt/p/2274766.html
Copyright © 2011-2022 走看看