zoukankan      html  css  js  c++  java
  • hdoj1014 互质

    Uniform Generator

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 35023    Accepted Submission(s): 13939

    Problem Description

    Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

    seed(x+1) = [seed(x) + STEP] % MOD

    where '%' is the modulus operator.

    Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1.
    For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations.
    If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1.
    Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers.

    Input

    Each line of input will contain a pair of integers for STEP and MOD in that order (1 <= STEP, MOD <= 100000).

    Output

    For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either "Good Choice" or "Bad Choice" left-justified starting in column 25. The "Good Choice" message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message "Bad Choice". After each output test set, your program should print exactly one blank line.

    Sample Input

    3 5 15 20 63923 99999

    Sample Output

    3 5 Good Choice 15 20 Bad Choice 63923 99999 Good Choice

    该题可以直接暴力求解,也可以找规律,实际上Good Choice当且仅当STEP和MOD互质,下面给出证明。

    分析:数论。随机数生成的数字的第x+1个数字为:

                seed(x) = (seed(x-1)+STEP)%MOD = (seed(x-1)%MOD + STEP%MOD)%MOD

                = (seed(x-2)%MOD + (STEP*2)%MOD)%MOD

                = ... = (seed(0)%MOD + (STEP*x)%MOD)%MOD

                如果不能生成全部序列一定存在 0 <= i <j < MOD 使得生成值相同,即:

                seed(i) = (seed(0)%MOD + (STEP*i)%MOD)%MOD

                seed(j) = (seed(0)%MOD + (STEP*j)%MOD)%MOD

               由seed(i) = seed(j) 可以得知 (STEP*(j-i))%MOD = 0 且 i ≠ j,即STEP*(j-i)为MOD的倍数:

               STEP*(j-i)=k*MOD  ->  (j-i)*STEP/MOD=k  (k属于Z)

               又因为 j-i < MOD 所以STEP和MOD必有一个大于1的公因子,即gcd( STEP,MOD ) > 1。

               由此可知,可以生成全部序列的充要条件是 gcd( STEP,MOD ) = 1。

    说明:注意输出格式,我在这PE过一次。。仔细看题目原来要求输出每个测试样例后输出一行空白。

    下面是AC代码:

    #include<cstdio>
    using namespace std;
    
    int gcd(int a,int b){
    	return b?gcd(b,a%b):a;
    }
    
    int main(){
    	int step,mod;
    	while(scanf("%d%d",&step,&mod)!=EOF){
    		int res=gcd(step,mod);
    		if(res==1)
    			printf("%10d%10d    Good Choice
    
    ",step,mod);
    		else
    			printf("%10d%10d    Bad Choice
    
    ",step,mod);
    	
    	}	
    	return 0;
    }
  • 相关阅读:
    4-8 求二叉树高度 (20分)
    汉诺塔的递归和非递归实现
    5-18 银行业务队列简单模拟 (25分)
    ACM 刷题小技巧【转】
    5-21 求前缀表达式的值(25分)
    5-20 表达式转换 (25分)
    约瑟夫环----循环链表问题
    关于埃拉托色尼筛选法的整理(质数问题)
    编码---隐藏在计算机软硬件背后的语言
    内排序和外排序扫盲
  • 原文地址:https://www.cnblogs.com/FrankChen831X/p/10326084.html
Copyright © 2011-2022 走看看